aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lbdb
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-03-31 12:27:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-03-31 12:57:51 +0000
commit84e3321b0e2aea4933bf352f70b54a83bcccb0dc (patch)
tree43fe23e12a7befe4a8cfa68a636dce00b9d56960 /testing/lbdb
parentff0bcf619294c673ad05f0434235bec55d2c1fbd (diff)
downloadaports-84e3321b0e2aea4933bf352f70b54a83bcccb0dc.tar.bz2
aports-84e3321b0e2aea4933bf352f70b54a83bcccb0dc.tar.xz
testing/lbdb: fix libdir and split -doc
Diffstat (limited to 'testing/lbdb')
-rw-r--r--testing/lbdb/APKBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/testing/lbdb/APKBUILD b/testing/lbdb/APKBUILD
index 06da547b20..e65bcfbb23 100644
--- a/testing/lbdb/APKBUILD
+++ b/testing/lbdb/APKBUILD
@@ -1,24 +1,32 @@
pkgname=lbdb
pkgver=0.39
-pkgrel=0
+pkgrel=1
pkgdesc="The little brother's database for the mutt mail reader"
-arch='x86 x86_64'
+arch='all'
url="http://www.spinnaker.de/lbdb/"
license="GPL"
depends='perl'
source="http://www.spinnaker.de/debian/${pkgname}_${pkgver}.tar.gz"
+subpackages="$pkgname-doc"
_builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
- ./configure --prefix=/usr --sysconfdir=/etc
- make
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib/lbdb \
+ --sysconfdir=/etc/lbdb \
+ || return 1
+ make
}
package() {
- cd "$_builddir"
- make install_prefix=$pkgdir install
+ cd "$_builddir"
+ make install_prefix="$pkgdir" \
+ sysconfdir=/etc/lbdb \
+ libdir=/usr/lib/lbdb \
+ install
}
md5sums="b4739fd4e331e41da8a634c24c98a2c8 lbdb_0.39.tar.gz"
sha256sums="4083ce4abde18ac949ca6eab453b3b7227a5aa2c737c9ad8ecbb0152fabfafc6 lbdb_0.39.tar.gz"