aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ldap-passwd-webui/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-07-14 01:50:05 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-07-14 01:52:22 +0200
commit7f5b226448aabbe9aed8018824713258e03b329f (patch)
tree0742e19f5b9cab5830f17c4bee088ca0ea2ca7f3 /testing/ldap-passwd-webui/APKBUILD
parentd1319b654fdf3ca52d0256cdb130b7b89bcbfd75 (diff)
downloadaports-7f5b226448aabbe9aed8018824713258e03b329f.tar.bz2
aports-7f5b226448aabbe9aed8018824713258e03b329f.tar.xz
testing/ldap-passwd-webui: new aport
https://github.com/jirutka/ldap-passwd-webui Very simple web interface for changing password stored in LDAP or Active Directory (Samba 4 AD)
Diffstat (limited to 'testing/ldap-passwd-webui/APKBUILD')
-rw-r--r--testing/ldap-passwd-webui/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/ldap-passwd-webui/APKBUILD b/testing/ldap-passwd-webui/APKBUILD
new file mode 100644
index 0000000000..24e51fe65f
--- /dev/null
+++ b/testing/ldap-passwd-webui/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=ldap-passwd-webui
+pkgver=2.0.0
+pkgrel=0
+pkgdesc="Very simple web interface for changing password stored in LDAP or Active Directory (Samba 4 AD)"
+url="https://github.com/jirutka/ldap-passwd-webui"
+arch="noarch"
+license="MIT"
+depends="python3 py3-bottle py3-ldap3"
+makedepends="python3-dev"
+subpackages="$pkgname-waitress"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jirutka/$pkgname/archive/v$pkgver.tar.gz
+ $pkgname.confd
+ settings.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+options="!check"
+
+package() {
+ local destdir="$pkgdir/usr/share/webapps/$pkgname"
+ cd "$builddir"
+
+ mkdir -p "$destdir"
+ cp -r static app.py index.tpl "$destdir"/
+
+ install -D -m 644 settings.ini.example "$pkgdir"/etc/$pkgname.ini
+}
+
+waitress() {
+ pkgdesc="Runscript for ldap-passwd-webui using Waitress WSGI server"
+ depends="$pkgname=$pkgver-r$pkgrel py-waitress"
+
+ mkdir -p "$subpkgdir"/etc/init.d
+ ln -s waitress "$subpkgdir"/etc/init.d/$pkgname
+ install -D -m 644 "$srcdir"/$pkgname.confd "$subpkgdir"/etc/conf.d/$pkgname
+}
+
+sha512sums="84ecb80ef633e9b3a04913ba0594a98e1e6372d47cdbc0330bb6f914b0b5ec84e1d2886717292d005556705eafbb74d86c85d37065feb9a9975ed393f36587b5 ldap-passwd-webui-2.0.0.tar.gz
+a1f10fbd2261e86ac249efe6571b6c42c398cd17566b602fb0a94e1c9c755da09e73ee7a1bd839181d552ffd74ea7e99352efb51b01a1a27db707e29312b8120 ldap-passwd-webui.confd
+e3200bb2495dfe0f233554c003fd2401ffdc6d86e29c1fbecb1f473f351bd4d2a97add2983d43828bed31c0afb23535cd99ff37c5d8343f304fe9edfa4ccc991 settings.patch"