aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ldoc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-06-25 08:55:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-06-25 09:04:14 +0000
commit8c8c4ac14ccec5762e1bf1d9a19db8301f47e0bc (patch)
tree6a17467cb91785c1ce4c32ba56a2c1e7ee80af9c /testing/ldoc
parent0a189d8bbe8e81f09e179ec8be1bff111eeb8684 (diff)
downloadaports-8c8c4ac14ccec5762e1bf1d9a19db8301f47e0bc.tar.bz2
aports-8c8c4ac14ccec5762e1bf1d9a19db8301f47e0bc.tar.xz
testing/ldoc: rename, upgrade to 1.3.13 and port to lua 5.2
This is an application and not a library so rename it to ldoc
Diffstat (limited to 'testing/ldoc')
-rw-r--r--testing/ldoc/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/ldoc/APKBUILD b/testing/ldoc/APKBUILD
new file mode 100644
index 0000000000..e42481215d
--- /dev/null
+++ b/testing/ldoc/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_luaver=5.2
+pkgname=ldoc
+pkgver=1.3.13
+pkgrel=0
+pkgdesc="Documentation tool for Lua"
+url="http://github.com/stevedonovan/LDoc"
+arch="noarch"
+license="MIT"
+depends="lua$_luaver-penlight lua$_luaver"
+makedepends=""
+install=""
+subpackages=
+source="http://stevedonovan.github.com/files/ldoc-$pkgver.zip"
+
+_luashare=/usr/share/lua/$_luaver
+_builddir="$srcdir"/ldoc
+prepare() {
+ local i
+ cd "$_builddir" || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ sed -i "1s:.*:#!/usr/bin/lua$_luaver:" ldoc.lua
+}
+
+build() {
+ cd "$_builddir"
+ find -type d | xargs chmod 755
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm755 ldoc.lua "$pkgdir"/usr/bin/ldoc || return 1
+ install -d "$pkgdir"/$_luashare || return 1
+ cp -a ldoc "$pkgdir"/$_luashare/
+}
+
+md5sums="f0b47e6d91ec1692491b05ba0d16cda4 ldoc-1.3.13.zip"
+sha256sums="ba65c5351085635a3dffc17aacd0cfc3279d534d51db8ae6537b97aea71d0d20 ldoc-1.3.13.zip"
+sha512sums="e5796692cdeba86687c398580f18e06f7d7afd53f040907d6d8ecc879a9136f59efcfc4d69af80562f22e1f76da449b2a765c6f295b0207c35c5403df4245936 ldoc-1.3.13.zip"