aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lib3mf
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2019-09-01 21:02:41 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-01 20:33:19 -0300
commit8c83d9b6582e773d3f76585ff05cf365b5dde302 (patch)
treec47d50b762c9dd369ecd6147f4e2d1ad799721a6 /testing/lib3mf
parent626566eded4031cb21a56da79b7b1be345879875 (diff)
downloadaports-8c83d9b6582e773d3f76585ff05cf365b5dde302.tar.bz2
aports-8c83d9b6582e773d3f76585ff05cf365b5dde302.tar.xz
testing/lib3mf: New aport
A C++ implementation of the 3D Manufacturing Format file standard https://github.com/3MFConsortium/lib3mf
Diffstat (limited to 'testing/lib3mf')
-rw-r--r--testing/lib3mf/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/lib3mf/APKBUILD b/testing/lib3mf/APKBUILD
new file mode 100644
index 0000000000..9cf73a1bb6
--- /dev/null
+++ b/testing/lib3mf/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=lib3mf
+pkgver=1.8.1
+_googletestver=1.8.1
+pkgrel=0
+pkgdesc="A C++ implementation of the 3D Manufacturing Format file standard"
+url="https://github.com/3MFConsortium/lib3mf"
+arch="all"
+license="BSD-2-Clause"
+subpackages="$pkgname-dev"
+makedepends="zlib-dev libzip-dev cmake util-linux-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/3MFConsortium/lib3mf/archive/v$pkgver.tar.gz"
+options="!check" # Unit tests requires source code of googletest, which is git submodule but not included in the release
+
+prepare() {
+ default_prepare
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_INCLUDEDIR=include/lib3mf \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DUSE_INCLUDED_ZLIB=OFF \
+ -DUSE_INCLUDED_LIBZIP=OFF \
+ -DLIB3MF_TESTS=FALSE \
+ ..
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="f7fd75bcb6472de1595a018e5add516d0d78ab0aee92462b686b77f8d2bef05270e7b737cb7e1d31fc5850815056e753874c2f9ec456a455e8461c4010fe914a lib3mf-1.8.1.tar.gz"