aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libappindicator/no-python.patch
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-12 01:17:19 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-12 01:20:35 -0300
commit9d7eef4be32bfc5da12372734c94fa28bfb07ba3 (patch)
treea7345de79204ce5adef333f807057ed0dc58f6c9 /testing/libappindicator/no-python.patch
parent9306f2d266cadef25f1af095c97199c8fe8ade14 (diff)
downloadaports-9d7eef4be32bfc5da12372734c94fa28bfb07ba3.tar.bz2
aports-9d7eef4be32bfc5da12372734c94fa28bfb07ba3.tar.xz
testing/libappindicator: new aport
https://launchpad.net/libappindicator Library that allow applications to export menus
Diffstat (limited to 'testing/libappindicator/no-python.patch')
-rw-r--r--testing/libappindicator/no-python.patch423
1 files changed, 423 insertions, 0 deletions
diff --git a/testing/libappindicator/no-python.patch b/testing/libappindicator/no-python.patch
new file mode 100644
index 0000000000..86aaf8b97f
--- /dev/null
+++ b/testing/libappindicator/no-python.patch
@@ -0,0 +1,423 @@
+diff --git a/bindings/Makefile.am b/bindings/Makefile.am
+index d1f6d73..dccca6c 100644
+--- a/bindings/Makefile.am
++++ b/bindings/Makefile.am
+@@ -3,7 +3,6 @@ SUBDIRS = \
+ vala
+ else
+ SUBDIRS = \
+- python \
+ vala
+ endif
+
+diff --git a/bindings/Makefile.in b/bindings/Makefile.in
+index e56458c..f869854 100644
+--- a/bindings/Makefile.in
++++ b/bindings/Makefile.in
+@@ -93,7 +93,7 @@ AM_RECURSIVE_TARGETS = $(RECURSIVE_TARGETS:-recursive=) \
+ distdir
+ ETAGS = etags
+ CTAGS = ctags
+-DIST_SUBDIRS = python vala mono
++DIST_SUBDIRS = vala mono
+ DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
+ am__relativize = \
+ dir0=`pwd`; \
+@@ -301,7 +301,7 @@ target_alias = @target_alias@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-@USE_GTK3_FALSE@SUBDIRS = python vala $(am__append_1)
++@USE_GTK3_FALSE@SUBDIRS = vala $(am__append_1)
+ @USE_GTK3_TRUE@SUBDIRS = vala $(am__append_1)
+ all: all-recursive
+
+diff --git a/configure b/configure
+index 5174b3f..5896f55 100755
+--- a/configure
++++ b/configure
+@@ -13702,365 +13702,6 @@ else
+ with_localinstall=no
+ fi
+
+-
+-###########################
+-# Python
+-###########################
+-
+-PYGTK_REQUIRED=2.14.0
+-PYGOBJECT_REQUIRED=0.22
+-
+-
+-
+-
+-
+- if test -n "$PYTHON"; then
+- # If the user set $PYTHON, use it and don't search something else.
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether $PYTHON version >= 2.3.5" >&5
+-$as_echo_n "checking whether $PYTHON version >= 2.3.5... " >&6; }
+- prog="import sys, string
+-# split strings by '.' and convert to numeric. Append some zeros
+-# because we need at least 4 digits for the hex conversion.
+-minver = map(int, string.split('2.3.5', '.')) + [0, 0, 0]
+-minverhex = 0
+-for i in xrange(0, 4): minverhex = (minverhex << 8) + minver[i]
+-sys.exit(sys.hexversion < minverhex)"
+- if { echo "$as_me:$LINENO: $PYTHON -c "$prog"" >&5
+- ($PYTHON -c "$prog") >&5 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; then :
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+-$as_echo "yes" >&6; }
+-else
+- as_fn_error $? "too old" "$LINENO" 5
+-fi
+- am_display_PYTHON=$PYTHON
+- else
+- # Otherwise, try each interpreter until we find one that satisfies
+- # VERSION.
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for a Python interpreter with version >= 2.3.5" >&5
+-$as_echo_n "checking for a Python interpreter with version >= 2.3.5... " >&6; }
+-if ${am_cv_pathless_PYTHON+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+-
+- for am_cv_pathless_PYTHON in python python2 python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5 none; do
+- test "$am_cv_pathless_PYTHON" = none && break
+- prog="import sys, string
+-# split strings by '.' and convert to numeric. Append some zeros
+-# because we need at least 4 digits for the hex conversion.
+-minver = map(int, string.split('2.3.5', '.')) + [0, 0, 0]
+-minverhex = 0
+-for i in xrange(0, 4): minverhex = (minverhex << 8) + minver[i]
+-sys.exit(sys.hexversion < minverhex)"
+- if { echo "$as_me:$LINENO: $am_cv_pathless_PYTHON -c "$prog"" >&5
+- ($am_cv_pathless_PYTHON -c "$prog") >&5 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; then :
+- break
+-fi
+- done
+-fi
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $am_cv_pathless_PYTHON" >&5
+-$as_echo "$am_cv_pathless_PYTHON" >&6; }
+- # Set $PYTHON to the absolute path of $am_cv_pathless_PYTHON.
+- if test "$am_cv_pathless_PYTHON" = none; then
+- PYTHON=:
+- else
+- # Extract the first word of "$am_cv_pathless_PYTHON", so it can be a program name with args.
+-set dummy $am_cv_pathless_PYTHON; ac_word=$2
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
+-$as_echo_n "checking for $ac_word... " >&6; }
+-if ${ac_cv_path_PYTHON+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- case $PYTHON in
+- [\\/]* | ?:[\\/]*)
+- ac_cv_path_PYTHON="$PYTHON" # Let the user override the test with a path.
+- ;;
+- *)
+- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+- IFS=$as_save_IFS
+- test -z "$as_dir" && as_dir=.
+- for ac_exec_ext in '' $ac_executable_extensions; do
+- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+- ac_cv_path_PYTHON="$as_dir/$ac_word$ac_exec_ext"
+- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
+- break 2
+- fi
+-done
+- done
+-IFS=$as_save_IFS
+-
+- ;;
+-esac
+-fi
+-PYTHON=$ac_cv_path_PYTHON
+-if test -n "$PYTHON"; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $PYTHON" >&5
+-$as_echo "$PYTHON" >&6; }
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+-fi
+-
+-
+- fi
+- am_display_PYTHON=$am_cv_pathless_PYTHON
+- fi
+-
+-
+- if test "$PYTHON" = :; then
+- as_fn_error $? "no suitable Python interpreter found" "$LINENO" 5
+- else
+-
+-
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for $am_display_PYTHON version" >&5
+-$as_echo_n "checking for $am_display_PYTHON version... " >&6; }
+-if ${am_cv_python_version+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- am_cv_python_version=`$PYTHON -c "import sys; print sys.version[:3]"`
+-fi
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $am_cv_python_version" >&5
+-$as_echo "$am_cv_python_version" >&6; }
+- PYTHON_VERSION=$am_cv_python_version
+-
+-
+-
+- PYTHON_PREFIX='${prefix}'
+-
+- PYTHON_EXEC_PREFIX='${exec_prefix}'
+-
+-
+-
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for $am_display_PYTHON platform" >&5
+-$as_echo_n "checking for $am_display_PYTHON platform... " >&6; }
+-if ${am_cv_python_platform+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- am_cv_python_platform=`$PYTHON -c "import sys; print sys.platform"`
+-fi
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $am_cv_python_platform" >&5
+-$as_echo "$am_cv_python_platform" >&6; }
+- PYTHON_PLATFORM=$am_cv_python_platform
+-
+-
+-
+-
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for $am_display_PYTHON script directory" >&5
+-$as_echo_n "checking for $am_display_PYTHON script directory... " >&6; }
+-if ${am_cv_python_pythondir+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- am_cv_python_pythondir=`$PYTHON -c "from distutils import sysconfig; print sysconfig.get_python_lib(0,0,prefix='$PYTHON_PREFIX')" 2>/dev/null ||
+- echo "$PYTHON_PREFIX/lib/python$PYTHON_VERSION/site-packages"`
+-fi
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $am_cv_python_pythondir" >&5
+-$as_echo "$am_cv_python_pythondir" >&6; }
+- pythondir=$am_cv_python_pythondir
+-
+-
+-
+- pkgpythondir=\${pythondir}/$PACKAGE
+-
+-
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for $am_display_PYTHON extension module directory" >&5
+-$as_echo_n "checking for $am_display_PYTHON extension module directory... " >&6; }
+-if ${am_cv_python_pyexecdir+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- am_cv_python_pyexecdir=`$PYTHON -c "from distutils import sysconfig; print sysconfig.get_python_lib(1,0,prefix='$PYTHON_EXEC_PREFIX')" 2>/dev/null ||
+- echo "${PYTHON_EXEC_PREFIX}/lib/python${PYTHON_VERSION}/site-packages"`
+-fi
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $am_cv_python_pyexecdir" >&5
+-$as_echo "$am_cv_python_pyexecdir" >&6; }
+- pyexecdir=$am_cv_python_pyexecdir
+-
+-
+-
+- pkgpyexecdir=\${pyexecdir}/$PACKAGE
+-
+-
+-
+- fi
+-
+-
+-
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for headers required to compile python extensions" >&5
+-$as_echo_n "checking for headers required to compile python extensions... " >&6; }
+-py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
+-py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
+-PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
+-if test "$py_prefix" != "$py_exec_prefix"; then
+- PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
+-fi
+-
+-save_CPPFLAGS="$CPPFLAGS"
+-CPPFLAGS="$CPPFLAGS $PYTHON_INCLUDES"
+-cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+-/* end confdefs.h. */
+-#include <Python.h>
+-_ACEOF
+-if ac_fn_c_try_cpp "$LINENO"; then :
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: found" >&5
+-$as_echo "found" >&6; }
+-
+-else
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: not found" >&5
+-$as_echo "not found" >&6; }
+-as_fn_error $? "could not find Python headers" "$LINENO" 5
+-fi
+-rm -f conftest.err conftest.i conftest.$ac_ext
+-CPPFLAGS="$save_CPPFLAGS"
+-
+-
+-
+-pkg_failed=no
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for APPINDICATOR_PYTHON" >&5
+-$as_echo_n "checking for APPINDICATOR_PYTHON... " >&6; }
+-
+-if test -n "$APPINDICATOR_PYTHON_CFLAGS"; then
+- pkg_cv_APPINDICATOR_PYTHON_CFLAGS="$APPINDICATOR_PYTHON_CFLAGS"
+- elif test -n "$PKG_CONFIG"; then
+- if test -n "$PKG_CONFIG" && \
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"
+- pygtk-2.0 >= \$PYGTK_REQUIRED
+- gtk+-2.0 >= \$GTK_REQUIRED_VERSION
+- pygobject-2.0 >= \$PYGOBJECT_REQUIRED
+- \""; } >&5
+- ($PKG_CONFIG --exists --print-errors "
+- pygtk-2.0 >= $PYGTK_REQUIRED
+- gtk+-2.0 >= $GTK_REQUIRED_VERSION
+- pygobject-2.0 >= $PYGOBJECT_REQUIRED
+- ") 2>&5
+- ac_status=$?
+- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+- test $ac_status = 0; }; then
+- pkg_cv_APPINDICATOR_PYTHON_CFLAGS=`$PKG_CONFIG --cflags "
+- pygtk-2.0 >= $PYGTK_REQUIRED
+- gtk+-2.0 >= $GTK_REQUIRED_VERSION
+- pygobject-2.0 >= $PYGOBJECT_REQUIRED
+- " 2>/dev/null`
+- test "x$?" != "x0" && pkg_failed=yes
+-else
+- pkg_failed=yes
+-fi
+- else
+- pkg_failed=untried
+-fi
+-if test -n "$APPINDICATOR_PYTHON_LIBS"; then
+- pkg_cv_APPINDICATOR_PYTHON_LIBS="$APPINDICATOR_PYTHON_LIBS"
+- elif test -n "$PKG_CONFIG"; then
+- if test -n "$PKG_CONFIG" && \
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"
+- pygtk-2.0 >= \$PYGTK_REQUIRED
+- gtk+-2.0 >= \$GTK_REQUIRED_VERSION
+- pygobject-2.0 >= \$PYGOBJECT_REQUIRED
+- \""; } >&5
+- ($PKG_CONFIG --exists --print-errors "
+- pygtk-2.0 >= $PYGTK_REQUIRED
+- gtk+-2.0 >= $GTK_REQUIRED_VERSION
+- pygobject-2.0 >= $PYGOBJECT_REQUIRED
+- ") 2>&5
+- ac_status=$?
+- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+- test $ac_status = 0; }; then
+- pkg_cv_APPINDICATOR_PYTHON_LIBS=`$PKG_CONFIG --libs "
+- pygtk-2.0 >= $PYGTK_REQUIRED
+- gtk+-2.0 >= $GTK_REQUIRED_VERSION
+- pygobject-2.0 >= $PYGOBJECT_REQUIRED
+- " 2>/dev/null`
+- test "x$?" != "x0" && pkg_failed=yes
+-else
+- pkg_failed=yes
+-fi
+- else
+- pkg_failed=untried
+-fi
+-
+-
+-
+-if test $pkg_failed = yes; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+-
+-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
+- _pkg_short_errors_supported=yes
+-else
+- _pkg_short_errors_supported=no
+-fi
+- if test $_pkg_short_errors_supported = yes; then
+- APPINDICATOR_PYTHON_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "
+- pygtk-2.0 >= $PYGTK_REQUIRED
+- gtk+-2.0 >= $GTK_REQUIRED_VERSION
+- pygobject-2.0 >= $PYGOBJECT_REQUIRED
+- " 2>&1`
+- else
+- APPINDICATOR_PYTHON_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "
+- pygtk-2.0 >= $PYGTK_REQUIRED
+- gtk+-2.0 >= $GTK_REQUIRED_VERSION
+- pygobject-2.0 >= $PYGOBJECT_REQUIRED
+- " 2>&1`
+- fi
+- # Put the nasty error message in config.log where it belongs
+- echo "$APPINDICATOR_PYTHON_PKG_ERRORS" >&5
+-
+- as_fn_error $? "Package requirements (
+- pygtk-2.0 >= $PYGTK_REQUIRED
+- gtk+-2.0 >= $GTK_REQUIRED_VERSION
+- pygobject-2.0 >= $PYGOBJECT_REQUIRED
+- ) were not met:
+-
+-$APPINDICATOR_PYTHON_PKG_ERRORS
+-
+-Consider adjusting the PKG_CONFIG_PATH environment variable if you
+-installed software in a non-standard prefix.
+-
+-Alternatively, you may set the environment variables APPINDICATOR_PYTHON_CFLAGS
+-and APPINDICATOR_PYTHON_LIBS to avoid the need to call pkg-config.
+-See the pkg-config man page for more details." "$LINENO" 5
+-elif test $pkg_failed = untried; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
+-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
+-as_fn_error $? "The pkg-config script could not be found or is too old. Make sure it
+-is in your PATH or set the PKG_CONFIG environment variable to the full
+-path to pkg-config.
+-
+-Alternatively, you may set the environment variables APPINDICATOR_PYTHON_CFLAGS
+-and APPINDICATOR_PYTHON_LIBS to avoid the need to call pkg-config.
+-See the pkg-config man page for more details.
+-
+-To get pkg-config, see <http://pkg-config.freedesktop.org/>.
+-See \`config.log' for more details" "$LINENO" 5; }
+-else
+- APPINDICATOR_PYTHON_CFLAGS=$pkg_cv_APPINDICATOR_PYTHON_CFLAGS
+- APPINDICATOR_PYTHON_LIBS=$pkg_cv_APPINDICATOR_PYTHON_LIBS
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+-$as_echo "yes" >&6; }
+-
+-fi
+-
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for pygtk defs" >&5
+-$as_echo_n "checking for pygtk defs... " >&6; }
+-PYGTK_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
+-
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $PYGTK_DEFSDIR" >&5
+-$as_echo "$PYGTK_DEFSDIR" >&6; }
+-
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for pygtk codegen" >&5
+-$as_echo_n "checking for pygtk codegen... " >&6; }
+-PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
+-
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $PYGTK_CODEGEN" >&5
+-$as_echo "$PYGTK_CODEGEN" >&6; }
+-
+ #########################
+ # Check if build tests
+ #########################
+@@ -14358,7 +13999,7 @@ fi
+ # Files
+ ###########################
+
+-ac_config_files="$ac_config_files Makefile src/Makefile src/appindicator-0.1.pc src/appindicator3-0.1.pc bindings/Makefile bindings/python/Makefile bindings/python/appindicator.override bindings/vala/Makefile bindings/vala/examples/Makefile tests/Makefile example/Makefile docs/Makefile docs/reference/Makefile docs/reference/version.xml docs/reference/libappindicator-docs.sgml"
++ac_config_files="$ac_config_files Makefile src/Makefile src/appindicator-0.1.pc src/appindicator3-0.1.pc bindings/Makefile bindings/vala/Makefile bindings/vala/examples/Makefile tests/Makefile example/Makefile docs/Makefile docs/reference/Makefile docs/reference/version.xml docs/reference/libappindicator-docs.sgml"
+
+
+ if test "x$has_mono" = "xtrue" ; then
+@@ -15437,8 +15078,6 @@ do
+ "src/appindicator-0.1.pc") CONFIG_FILES="$CONFIG_FILES src/appindicator-0.1.pc" ;;
+ "src/appindicator3-0.1.pc") CONFIG_FILES="$CONFIG_FILES src/appindicator3-0.1.pc" ;;
+ "bindings/Makefile") CONFIG_FILES="$CONFIG_FILES bindings/Makefile" ;;
+- "bindings/python/Makefile") CONFIG_FILES="$CONFIG_FILES bindings/python/Makefile" ;;
+- "bindings/python/appindicator.override") CONFIG_FILES="$CONFIG_FILES bindings/python/appindicator.override" ;;
+ "bindings/vala/Makefile") CONFIG_FILES="$CONFIG_FILES bindings/vala/Makefile" ;;
+ "bindings/vala/examples/Makefile") CONFIG_FILES="$CONFIG_FILES bindings/vala/examples/Makefile" ;;
+ "tests/Makefile") CONFIG_FILES="$CONFIG_FILES tests/Makefile" ;;
+