aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libasyncns
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-12-22 23:08:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-16 13:53:58 +0000
commit0766f1f5d2d9f31388774e1f3fcfa8cf67c36074 (patch)
tree50483385bfe09a5504e1a9413a409f4cdbdc7918 /testing/libasyncns
parent1e5183ee6e07480e59d1863094d74795a8a8662f (diff)
downloadaports-0766f1f5d2d9f31388774e1f3fcfa8cf67c36074.tar.bz2
aports-0766f1f5d2d9f31388774e1f3fcfa8cf67c36074.tar.xz
Initial APKBUILD for libasyncns
Package description: A small and lightweight library that implements easy to use asynchronous wrappers around the libc NSS functions getaddrinfo(), res_query() and related. Website: http://0pointer.de/lennart/projects/libasyncns/
Diffstat (limited to 'testing/libasyncns')
-rw-r--r--testing/libasyncns/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/libasyncns/APKBUILD b/testing/libasyncns/APKBUILD
new file mode 100644
index 0000000000..edb57b1de1
--- /dev/null
+++ b/testing/libasyncns/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=libasyncns
+pkgver=0.8
+pkgrel=0
+pkgdesc="Asynchronous Name Service Library"
+url="http://0pointer.de/lennart/projects/libasyncns/"
+arch="all"
+license="LGPL2+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://0pointer.de/lennart/projects/$pkgname/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --disable-static \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="1f553d6ce1ad255bc83b3d8e9384f515 libasyncns-0.8.tar.gz"