aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libbpf/20-trailing-ldflags.patch
diff options
context:
space:
mode:
authorAdam Jensen <acjensen@gmail.com>2019-05-12 18:34:43 -0400
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-14 10:49:39 +0000
commit9925e648a61b88ab2158a3d0680acda6799917f1 (patch)
tree1ef430b30615e86c9a2b02281aaca462ff95a58b /testing/libbpf/20-trailing-ldflags.patch
parent2740d7c334747a50b829ccde72ba88db601485a9 (diff)
downloadaports-9925e648a61b88ab2158a3d0680acda6799917f1.tar.bz2
aports-9925e648a61b88ab2158a3d0680acda6799917f1.tar.xz
testing/libbpf: new aport
https://github.com/libbpf/libbpf A library for interacting with the Linux kernel's Berkeley Packet Filter (BPF) facility from user space Closes GH-7860
Diffstat (limited to 'testing/libbpf/20-trailing-ldflags.patch')
-rw-r--r--testing/libbpf/20-trailing-ldflags.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/libbpf/20-trailing-ldflags.patch b/testing/libbpf/20-trailing-ldflags.patch
new file mode 100644
index 0000000000..7f65ef5645
--- /dev/null
+++ b/testing/libbpf/20-trailing-ldflags.patch
@@ -0,0 +1,29 @@
+diff --git a/src/Makefile b/src/Makefile
+index e9021fe..1d86ecd 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -54,11 +54,7 @@ INSTALL = install
+
+ DESTDIR ?=
+
+-ifeq ($(shell uname -m),x86_64)
+- LIBSUBDIR := lib64
+-else
+- LIBSUBDIR := lib
+-endif
++LIBSUBDIR := lib
+
+ PREFIX ?= /usr
+ LIBDIR ?= $(PREFIX)/$(LIBSUBDIR)
+@@ -77,9 +73,9 @@ $(OBJDIR)/libbpf.so.$(VERSION): $(OBJDIR)/libbpf.so.$(LIBBPF_VERSION)
+ ln -sf $(^F) $@
+
+ $(OBJDIR)/libbpf.so.$(LIBBPF_VERSION): $(OBJS)
+- $(CC) -shared $(ALL_LDFLAGS) -Wl,--version-script=$(VERSION_SCRIPT) \
++ $(CC) -shared -Wl,--version-script=$(VERSION_SCRIPT) \
+ -Wl,-soname,libbpf.so.$(VERSION) \
+- $^ -o $@
++ $^ -o $@ $(ALL_LDFLAGS)
+
+ $(OBJDIR)/libbpf.pc:
+ sed -e "s|@PREFIX@|$(PREFIX)|" \