aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libcoap
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-03-12 23:26:19 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2017-03-13 12:22:21 +0100
commit34fd89fac42a0272589b0225586c4d0f17659c84 (patch)
tree9f5c5d29443bbba24fb91e0ef458203ab19805ef /testing/libcoap
parent375f5f18399ef5d24b7853f4f4eb7c90169e5baa (diff)
downloadaports-34fd89fac42a0272589b0225586c4d0f17659c84.tar.bz2
aports-34fd89fac42a0272589b0225586c4d0f17659c84.tar.xz
testing/libcoap: new aport
Diffstat (limited to 'testing/libcoap')
-rw-r--r--testing/libcoap/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/testing/libcoap/APKBUILD b/testing/libcoap/APKBUILD
new file mode 100644
index 0000000000..af91aeb9c5
--- /dev/null
+++ b/testing/libcoap/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=libcoap
+pkgver=4.1.2
+pkgrel=0
+pkgdesc="A CoAP (RFC 7252) implementation"
+url="https://github.com/obgm/libcoap"
+arch="all"
+license="BSD GPL2+"
+depends=""
+depends_dev=""
+makedepends="automake autoconf libtool asciidoc"
+checkdepends="cunit-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/obgm/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/libcoap-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ ./autogen.sh || return 1
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-tests \
+ || return 1
+ make || return 1
+}
+
+check() {
+ "$builddir"/tests/testdriver || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname
+ install -m644 CONTRIBUTE AUTHORS ChangeLog NEWS README.md TODO \
+ "$pkgdir"/usr/share/doc/$pkgname || return 1
+}
+
+sha512sums="151f40cdacddf25bdffe367b4f1e3bf295445eac966db7bcf6692047cd9d5476b726f08c8d1de7dbe4ebe2477162b4df5e6c121e24eac79f9a4041ab2a646be6 libcoap-4.1.2.tar.gz"