aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libcypher-parser
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-19 13:16:17 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-19 13:16:17 -0300
commit75af9adb6f8c879b84e5962b307cc92007dcdc73 (patch)
tree0e9f1311125f56502df34dd3dba0304887a1f8c0 /testing/libcypher-parser
parent370d4f4199195d1435a1664a5153c96fd3e30303 (diff)
downloadaports-75af9adb6f8c879b84e5962b307cc92007dcdc73.tar.bz2
aports-75af9adb6f8c879b84e5962b307cc92007dcdc73.tar.xz
testing/libcypher-parser: upgrade to 0.6.2
Diffstat (limited to 'testing/libcypher-parser')
-rw-r--r--testing/libcypher-parser/APKBUILD75
1 files changed, 33 insertions, 42 deletions
diff --git a/testing/libcypher-parser/APKBUILD b/testing/libcypher-parser/APKBUILD
index ba7893eb9e..d2b02dd18e 100644
--- a/testing/libcypher-parser/APKBUILD
+++ b/testing/libcypher-parser/APKBUILD
@@ -1,70 +1,61 @@
# Contributor: Chris Leishman <chris@leishman.org>
# Maintainer: Chris Leishman <chris@leishman.org>
pkgname=libcypher-parser
-pkgver=0.6.0
+pkgver=0.6.2
pkgrel=0
pkgdesc="Parsing library for the Cypher query language"
url="https://github.com/cleishm/libcypher-parser"
arch="all"
license="Apache-2.0"
-depends=""
-depends_dev=""
makedepends="$depends_dev automake autoconf libtool check-dev doxygen pkgconfig"
-install=""
subpackages="$pkgname-dev $pkgname-doc::noarch cypher-lint cypher-lint-doc::noarch"
-source="https://github.com/cleishm/libcypher-parser/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/cleishm/libcypher-parser/releases/download/v$pkgver/libcypher-parser-$pkgver.tar.gz"
-builddir="$srcdir"/"$pkgname-$pkgver"
build() {
- cd "$builddir"
- ./configure \
- --prefix=/usr
- make
- make doc
+ ./configure \
+ --prefix=/usr
+ make
}
check() {
- cd "$builddir"
- make check
+ make check
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
- mkdir -p "$pkgdir"/usr/share/doc/libcypher-parser
- mv doc/html/* "$pkgdir"/usr/share/doc/libcypher-parser/
+ make DESTDIR="$pkgdir" install
+ mkdir -p "$pkgdir"/usr/share/doc/libcypher-parser
}
doc() {
- depends="$depends_doc"
- pkgdesc="$pkgdesc (documentation)"
- install_if="docs $pkgname=$pkgver-r$pkgrel"
-
- if [ "$subpkgname" = "libcypher-parser-doc" ]; then
- mkdir -p "$subpkgdir"/usr/share
- mv "$pkgdir"/usr/share/doc "$subpkgdir"/usr/share/
- elif [ "$subpkgname" = "cypher-lint-doc" ]; then
- mkdir -p "$subpkgdir"/usr/share
- mv "$pkgdir"/usr/share/man "$subpkgdir"/usr/share/
- find "$subpkgdir"/usr/share/man/ -type f | xargs gzip -9
- else
- die "Unknown doc package $pkgname"
- fi
-
- # remove if empty, ignore error (not empty)
- rmdir "$pkgdir"/usr/share "$pkgdir"/usr || true 2>/dev/null
- return 0
+ depends="$depends_doc"
+ pkgdesc="$pkgdesc (documentation)"
+ install_if="docs $pkgname=$pkgver-r$pkgrel"
+
+ if [ "$subpkgname" = "libcypher-parser-doc" ]; then
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/doc "$subpkgdir"/usr/share/
+ elif [ "$subpkgname" = "cypher-lint-doc" ]; then
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/man "$subpkgdir"/usr/share/
+ find "$subpkgdir"/usr/share/man/ -type f | xargs gzip -9
+ else
+ die "Unknown doc package $pkgname"
+ fi
+
+ # remove if empty, ignore error (not empty)
+ rmdir "$pkgdir"/usr/share "$pkgdir"/usr || true 2>/dev/null
+ return 0
}
lint() {
- pkgdesc="Lint tool for the Cypher query language"
+ pkgdesc="Lint tool for the Cypher query language"
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
- # remove if empty, ignore error (not empty)
- rmdir "$pkgdir"/usr/bin "$pkgdir"/usr || true 2>/dev/null
- return 0
+ # remove if empty, ignore error (not empty)
+ rmdir "$pkgdir"/usr/bin "$pkgdir"/usr || true 2>/dev/null
+ return 0
}
-sha512sums="5faabbfe09a98ad5805a533dfdf1ba3e3357d4320a274242472ef27fc3696d48a4b0bad1606ab6092aae111fc1d7f7c9c3fa875433d6c94bc1e03f2428ca889e libcypher-parser-0.6.0.tar.gz"
+sha512sums="71d1fd966c2d7e5637be1b59a17483cf8a782aa75582f4dcc64e0ea7b3f50c80cbf92cf07df2c601aeaa1186910a0e3b529c58da1318a34357f8c860f8e97361 libcypher-parser-0.6.2.tar.gz"