aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libgpiod/APKBUILD
diff options
context:
space:
mode:
authorLuca Weiss <luca@z3ntu.xyz>2019-07-19 15:21:50 +0200
committerprspkt <prspkt@protonmail.com>2019-07-20 16:15:11 +0300
commit24922699299955c639b32b39753168733853dfa2 (patch)
treed12bc63baea22a7636f3b5998e0daa56d28ea589 /testing/libgpiod/APKBUILD
parentd87805e5da7f0e286862b66e5221917f8d275ebb (diff)
downloadaports-24922699299955c639b32b39753168733853dfa2.tar.bz2
aports-24922699299955c639b32b39753168733853dfa2.tar.xz
testing/libgpiod: upgrade to 1.4
* Update configuration in the prepare function instead of build.
Diffstat (limited to 'testing/libgpiod/APKBUILD')
-rw-r--r--testing/libgpiod/APKBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/testing/libgpiod/APKBUILD b/testing/libgpiod/APKBUILD
index ddbece54be..29a3538ea6 100644
--- a/testing/libgpiod/APKBUILD
+++ b/testing/libgpiod/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: vinymeuh <vinymeuh@gmail.com>
# Maintainer: vinymeuh <vinymeuh@gmail.com>
pkgname=libgpiod
-pkgver=1.2
+pkgver=1.4
pkgrel=0
pkgdesc="C library and tools for interacting with the linux GPIO character device"
url="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/"
@@ -12,11 +12,20 @@ makedepends="autoconf automake libtool linux-headers autoconf-archive"
subpackages="$pkgname-dev"
source="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/snapshot/$pkgname-$pkgver.tar.gz"
+prepare() {
+ default_prepare
+ autoreconf -vfi
+}
+
build() {
- ./autogen.sh \
+ ./configure \
--build=$CBUILD \
- --enable-tools=yes \
+ --host=$CHOST \
--prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-tools=yes \
--disable-static
make
}
@@ -24,4 +33,5 @@ build() {
package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="58a4f0d1c59c754f13de6b45b8cf3c6c69a2860d029ac74f1f8e17bb2da846905c6d4085d7d1b0fe6c09e171dd04e18dc2279cd5a548d183f8f1566f0ef5a67e libgpiod-1.2.tar.gz"
+
+sha512sums="a1d55462fd0a03b437c2cb957d23697db135d5e97989a6e9a4915b6db35176fdae526fcc1ad44c13e8b216422a8196f7c866165a553cd2078843f7bb6226e28b libgpiod-1.4.tar.gz"