aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libgpiod
diff options
context:
space:
mode:
authorvinymeuh <vinymeuh@gmail.com>2018-12-18 20:40:42 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-06-14 09:26:14 -0300
commit127784aeb3384f55fb1795d2c2da3fea715a7fbd (patch)
tree9228510e53051dc21f553d5e396f7b0ec96d3688 /testing/libgpiod
parent22a0e3d4c993da5413ff0e6390accb7168307ee0 (diff)
downloadaports-127784aeb3384f55fb1795d2c2da3fea715a7fbd.tar.bz2
aports-127784aeb3384f55fb1795d2c2da3fea715a7fbd.tar.xz
testing/libgpiod: new aport
https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/ C library and tools for interacting with the linux GPIO character device
Diffstat (limited to 'testing/libgpiod')
-rw-r--r--testing/libgpiod/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/libgpiod/APKBUILD b/testing/libgpiod/APKBUILD
new file mode 100644
index 0000000000..ddbece54be
--- /dev/null
+++ b/testing/libgpiod/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: vinymeuh <vinymeuh@gmail.com>
+# Maintainer: vinymeuh <vinymeuh@gmail.com>
+pkgname=libgpiod
+pkgver=1.2
+pkgrel=0
+pkgdesc="C library and tools for interacting with the linux GPIO character device"
+url="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/"
+arch="all"
+license="LGPL-2.1-or-later"
+options="!check" # no test suite
+makedepends="autoconf automake libtool linux-headers autoconf-archive"
+subpackages="$pkgname-dev"
+source="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/snapshot/$pkgname-$pkgver.tar.gz"
+
+build() {
+ ./autogen.sh \
+ --build=$CBUILD \
+ --enable-tools=yes \
+ --prefix=/usr \
+ --disable-static
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="58a4f0d1c59c754f13de6b45b8cf3c6c69a2860d029ac74f1f8e17bb2da846905c6d4085d7d1b0fe6c09e171dd04e18dc2279cd5a548d183f8f1566f0ef5a67e libgpiod-1.2.tar.gz"