aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libgpod/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-07-20 08:44:23 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-07-20 08:44:23 +0000
commit617a9b331dc33df2b771d681689effcb27784c50 (patch)
tree766636cb1fb22a428eac5555e5898dcf7c650902 /testing/libgpod/APKBUILD
parentf2b63db40b5e06abc48d2c7d18be0b7e18f728f5 (diff)
downloadaports-617a9b331dc33df2b771d681689effcb27784c50.tar.bz2
aports-617a9b331dc33df2b771d681689effcb27784c50.tar.xz
testing/libgpod: new aport
Diffstat (limited to 'testing/libgpod/APKBUILD')
-rw-r--r--testing/libgpod/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/libgpod/APKBUILD b/testing/libgpod/APKBUILD
new file mode 100644
index 0000000000..c9831d4c79
--- /dev/null
+++ b/testing/libgpod/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=libgpod
+pkgver=0.8.3
+pkgrel=0
+pkgdesc="A shared library to access the contents of an iPod"
+url="http://www.gtkpod.org/libgpod"
+arch="all"
+license="LGPL"
+makedepends="automake autoconf libtool intltool libimobiledevice-dev libplist-dev
+ swig py-gobject-dev mutagen sg3_utils-dev gdk-pixbuf-dev
+ glib-dev sqlite-dev gobject-introspection-dev libxml2-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://downloads.sourceforge.net/sourceforge/gtkpod/${pkgname}-${pkgver}.tar.bz2
+ 0001-323-Segmentation-fault-when-opening-ipod.patch
+ libgpod-0.8.2-pkgconfig_overlinking.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+build() {
+ cd "$builddir"
+ MCS=/usr/bin/mcs ./configure \
+ --prefix=/usr \
+ --with-udev-dir=/usr/lib/udev \
+ --enable-udev \
+ --with-python=/usr/bin/python2
+ make PREFIX=/usr
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+}
+
+sha512sums="e39f22054c2d2bdf5fc764aa1f692de17a1a06c7c7e9c60883d126b216dacca7840bf818e7e7e039218fe2a64c0920ba96d8cbbe310e11c1c4e68b82e7cbbd8e libgpod-0.8.3.tar.bz2
+d1a813a45230ca716e0c6ed5497d68089762ce5b4cac9462f1959083fdf40bedbf7449a55d63170800d74372921fad02a9d5a3146e9f8ed652ffd58238360b49 0001-323-Segmentation-fault-when-opening-ipod.patch
+c8ebcc18ba7b44aef8fada3f9fea88fdaaf6bae12cf809b08f98e85ab6396ae032bfd7706809cd266be67c694749d4364a9cc591eb750478e095cbbcbe061419 libgpod-0.8.2-pkgconfig_overlinking.patch"