aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libgpod
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-07-20 08:44:23 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-07-20 08:44:23 +0000
commit617a9b331dc33df2b771d681689effcb27784c50 (patch)
tree766636cb1fb22a428eac5555e5898dcf7c650902 /testing/libgpod
parentf2b63db40b5e06abc48d2c7d18be0b7e18f728f5 (diff)
downloadaports-617a9b331dc33df2b771d681689effcb27784c50.tar.bz2
aports-617a9b331dc33df2b771d681689effcb27784c50.tar.xz
testing/libgpod: new aport
Diffstat (limited to 'testing/libgpod')
-rw-r--r--testing/libgpod/0001-323-Segmentation-fault-when-opening-ipod.patch43
-rw-r--r--testing/libgpod/APKBUILD42
-rw-r--r--testing/libgpod/libgpod-0.8.2-pkgconfig_overlinking.patch11
3 files changed, 96 insertions, 0 deletions
diff --git a/testing/libgpod/0001-323-Segmentation-fault-when-opening-ipod.patch b/testing/libgpod/0001-323-Segmentation-fault-when-opening-ipod.patch
new file mode 100644
index 0000000000..727f18b370
--- /dev/null
+++ b/testing/libgpod/0001-323-Segmentation-fault-when-opening-ipod.patch
@@ -0,0 +1,43 @@
+From 8dc5015ae036b219c4c9579a156886aa3a722aa5 Mon Sep 17 00:00:00 2001
+From: phantomjinx <p.g.richardson@phantomjinx.co.uk>
+Date: Sat, 9 Aug 2014 19:57:10 +0100
+Subject: [PATCH] #323 Segmentation fault when opening ipod
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+* Patch submitted in bug report from François Melchior / James Burton
+---
+ src/itdb_itunesdb.c | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/src/itdb_itunesdb.c b/src/itdb_itunesdb.c
+index 4cc771a..1e85476 100644
+--- a/src/itdb_itunesdb.c
++++ b/src/itdb_itunesdb.c
+@@ -1156,6 +1156,7 @@ static gboolean playcounts_plist_read (FImport *fimp, GValue *plist_data)
+ GHashTable *pc_dict, *track_dict;
+ GValue *to_parse;
+ GArray *array;
++ GValue value;
+ gint i;
+ guint32 mac_time;
+ guint64 *dbid;
+@@ -1175,11 +1176,12 @@ static gboolean playcounts_plist_read (FImport *fimp, GValue *plist_data)
+
+ array = (GArray*)g_value_get_boxed (to_parse);
+ for (i = 0; i < array->len; i++) {
+- if (!G_VALUE_HOLDS (g_array_index (array, GValue *, i), G_TYPE_HASH_TABLE)) {
++ value = g_array_index (array, GValue, i);
++ if (!G_VALUE_HOLDS (&value, G_TYPE_HASH_TABLE)) {
+ continue;
+ }
+
+- track_dict = g_value_get_boxed (g_array_index (array, GValue *, i));
++ track_dict = g_value_get_boxed (&value);
+ if (track_dict == NULL)
+ continue;
+
+--
+2.12.2
+
diff --git a/testing/libgpod/APKBUILD b/testing/libgpod/APKBUILD
new file mode 100644
index 0000000000..c9831d4c79
--- /dev/null
+++ b/testing/libgpod/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=libgpod
+pkgver=0.8.3
+pkgrel=0
+pkgdesc="A shared library to access the contents of an iPod"
+url="http://www.gtkpod.org/libgpod"
+arch="all"
+license="LGPL"
+makedepends="automake autoconf libtool intltool libimobiledevice-dev libplist-dev
+ swig py-gobject-dev mutagen sg3_utils-dev gdk-pixbuf-dev
+ glib-dev sqlite-dev gobject-introspection-dev libxml2-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://downloads.sourceforge.net/sourceforge/gtkpod/${pkgname}-${pkgver}.tar.bz2
+ 0001-323-Segmentation-fault-when-opening-ipod.patch
+ libgpod-0.8.2-pkgconfig_overlinking.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+build() {
+ cd "$builddir"
+ MCS=/usr/bin/mcs ./configure \
+ --prefix=/usr \
+ --with-udev-dir=/usr/lib/udev \
+ --enable-udev \
+ --with-python=/usr/bin/python2
+ make PREFIX=/usr
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+}
+
+sha512sums="e39f22054c2d2bdf5fc764aa1f692de17a1a06c7c7e9c60883d126b216dacca7840bf818e7e7e039218fe2a64c0920ba96d8cbbe310e11c1c4e68b82e7cbbd8e libgpod-0.8.3.tar.bz2
+d1a813a45230ca716e0c6ed5497d68089762ce5b4cac9462f1959083fdf40bedbf7449a55d63170800d74372921fad02a9d5a3146e9f8ed652ffd58238360b49 0001-323-Segmentation-fault-when-opening-ipod.patch
+c8ebcc18ba7b44aef8fada3f9fea88fdaaf6bae12cf809b08f98e85ab6396ae032bfd7706809cd266be67c694749d4364a9cc591eb750478e095cbbcbe061419 libgpod-0.8.2-pkgconfig_overlinking.patch"
diff --git a/testing/libgpod/libgpod-0.8.2-pkgconfig_overlinking.patch b/testing/libgpod/libgpod-0.8.2-pkgconfig_overlinking.patch
new file mode 100644
index 0000000000..a5dafb2857
--- /dev/null
+++ b/testing/libgpod/libgpod-0.8.2-pkgconfig_overlinking.patch
@@ -0,0 +1,11 @@
+diff -up libgpod-0.8.2/libgpod-1.0.pc.in.pkgconfig_overlinking libgpod-0.8.2/libgpod-1.0.pc.in
+--- libgpod-0.8.2/libgpod-1.0.pc.in.pkgconfig_overlinking 2011-04-15 03:37:34.000000000 -0500
++++ libgpod-0.8.2/libgpod-1.0.pc.in 2012-08-10 13:53:00.294631805 -0500
+@@ -6,6 +6,6 @@ includedir=@includedir@
+ Name: libgpod
+ Description: A library to manipulate songs and playlists stored on an ipod
+ Version: @VERSION@
+-Requires: glib-2.0 >= 2.8.0 gobject-2.0 @GDKPIXBUF_REQ@ @LIBIMOBILEDEVICE_REQ@
++Requires.private: glib-2.0 >= 2.8.0 gobject-2.0 @GDKPIXBUF_REQ@ @LIBIMOBILEDEVICE_REQ@
+ Libs: -L${libdir} -lgpod
+ Cflags: -I${includedir}/gpod-1.0