aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libgpod
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-13 20:18:06 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-13 22:56:25 -0300
commitc54dc7d6dec45155410bc40129f7fb8211b6c406 (patch)
tree6116ebbfe9c5e2514b3a780f9f1b5d68b5deda62 /testing/libgpod
parent43ff74ccf444730ad67eba844d3a4377b9908563 (diff)
downloadaports-c54dc7d6dec45155410bc40129f7fb8211b6c406.tar.bz2
aports-c54dc7d6dec45155410bc40129f7fb8211b6c406.tar.xz
testing/libgpod: drop py- bindings
Diffstat (limited to 'testing/libgpod')
-rw-r--r--testing/libgpod/APKBUILD25
1 files changed, 11 insertions, 14 deletions
diff --git a/testing/libgpod/APKBUILD b/testing/libgpod/APKBUILD
index af1f214f68..570e1ecf2a 100644
--- a/testing/libgpod/APKBUILD
+++ b/testing/libgpod/APKBUILD
@@ -2,41 +2,38 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=libgpod
pkgver=0.8.3
-pkgrel=1
+pkgrel=2
pkgdesc="A shared library to access the contents of an iPod"
url="http://www.gtkpod.org/libgpod"
arch="all"
-license="LGPL"
-makedepends="automake autoconf libtool intltool libimobiledevice-dev libplist-dev
- swig py-gobject-dev mutagen sg3_utils-dev gdk-pixbuf-dev
- glib-dev sqlite-dev gobject-introspection-dev libxml2-dev"
+license="LGPL-2.1-or-later"
+makedepends="automake autoconf libtool intltool libimobiledevice-dev libplist-dev
+ swig mutagen sg3_utils-dev gdk-pixbuf-dev glib-dev sqlite-dev
+ gobject-introspection-dev libxml2-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://downloads.sourceforge.net/project/gtkpod/$pkgname/$pkgname-0.8/$pkgname-$pkgver.tar.bz2
+source="https://downloads.sourceforge.net/project/gtkpod/libgpod/libgpod-0.8/libgpod-$pkgver.tar.bz2
0001-323-Segmentation-fault-when-opening-ipod.patch
0002-Fix-spelling-errors-in-comments-and-strings-using-co.patch
0003-Fixed-PList-deprecation.patch
libgpod-0.8.2-pkgconfig_overlinking.patch"
-builddir="$srcdir/$pkgname-$pkgver"
+
+replaces="py-libgpod" # Removed in 0.8.3-r2
check() {
- cd "$builddir"
make check
}
build() {
- cd "$builddir"
MCS=/usr/bin/mcs ./configure \
--prefix=/usr \
--with-udev-dir=/lib/udev \
- --enable-udev \
- --with-python=/usr/bin/python2
+ --enable-udev
make PREFIX=/usr
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
}
package() {
- cd "$builddir"
- make PREFIX=/usr DESTDIR="${pkgdir}" install
+ make PREFIX=/usr DESTDIR="$pkgdir" install
}
sha512sums="e39f22054c2d2bdf5fc764aa1f692de17a1a06c7c7e9c60883d126b216dacca7840bf818e7e7e039218fe2a64c0920ba96d8cbbe310e11c1c4e68b82e7cbbd8e libgpod-0.8.3.tar.bz2