aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libguestfs
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-26 01:37:29 -0300
committerTBK <tbk@jjtc.eu>2019-05-26 15:19:30 +0200
commitd99915c2b447035d78a5ed1d2b1ebeabbf2d796e (patch)
tree8881afebd8931738fa067bccfa864909cc3610fc /testing/libguestfs
parent15a83dd81fc4b8dbdab67e9ecb1e2ae1ac3bc502 (diff)
downloadaports-d99915c2b447035d78a5ed1d2b1ebeabbf2d796e.tar.bz2
aports-d99915c2b447035d78a5ed1d2b1ebeabbf2d796e.tar.xz
testing/libguestfs: modernize, fix license
Closes: GH-8131
Diffstat (limited to 'testing/libguestfs')
-rw-r--r--testing/libguestfs/APKBUILD13
1 files changed, 2 insertions, 11 deletions
diff --git a/testing/libguestfs/APKBUILD b/testing/libguestfs/APKBUILD
index f8851a69d2..1bff29eddc 100644
--- a/testing/libguestfs/APKBUILD
+++ b/testing/libguestfs/APKBUILD
@@ -1,18 +1,17 @@
# Maintainer: Fathi Boudra <fathi.boudra@linaro.org>
pkgname=libguestfs
pkgver=1.40.2
-pkgrel=2
+pkgrel=3
pkgdesc="tools for accessing and modifying virtual machine disk images"
url="http://libguestfs.org/"
arch="x86_64"
-license="GPL2"
+license="GPL-2.0-or-later"
depends="cdrkit curl gptfdisk qemu-img qemu-system-x86_64"
makedepends="
acl-dev
augeas-dev
bash
bison
- cdrkit
coreutils
cpio
file-dev
@@ -23,7 +22,6 @@ makedepends="
hivex-dev
jansson-dev
gperf
- gptfdisk
libcap-dev
libconfig-dev
libselinux-dev
@@ -39,23 +37,18 @@ makedepends="
perl
psmisc
python3-dev
- qemu-img
- qemu-system-x86_64
readline-dev
xz
xz-dev
"
-install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang py3-$pkgname:_py"
source="
http://download.libguestfs.org/1.40-stable/$pkgname-$pkgver.tar.gz
https://raw.githubusercontent.com/alpinelinux/aports/3.9-stable/main/kbd/error.h
"
-builddir="$srcdir/$pkgname-$pkgver"
options="!check charset.alias" # Test suite does not support Alpine Linux at this moment
prepare() {
- cd "$builddir"
# busybox gzip does not support --best
sed -i 's/gzip --best/gzip -9/g' test-data/files/*
# musl lacks error.h
@@ -63,7 +56,6 @@ prepare() {
}
build() {
- cd "$builddir"
PYTHON=/usr/bin/python3 ./configure \
--prefix=/usr \
--mandir=/usr/share/man \
@@ -99,7 +91,6 @@ build() {
# }
package() {
- cd "$builddir"
make V=1 INSTALLDIRS=vendor DESTDIR="$pkgdir" install
make V=1 INSTALLDIRS=vendor DESTDIR="$pkgdir" -C python install
}