aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libibmad
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-06 07:20:57 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-06 11:08:19 -0300
commita0424c024fa5c8db149dd94e2a716902de691e3b (patch)
tree3af02fee38ab24eb2d7d3e0db163c4d720cdcb33 /testing/libibmad
parent34da5fa15dd01bfe1d61ad56eb8941a6553e792b (diff)
downloadaports-a0424c024fa5c8db149dd94e2a716902de691e3b.tar.bz2
aports-a0424c024fa5c8db149dd94e2a716902de691e3b.tar.xz
testing/libibmad: modernize, fix license, fix url
Diffstat (limited to 'testing/libibmad')
-rw-r--r--testing/libibmad/APKBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/testing/libibmad/APKBUILD b/testing/libibmad/APKBUILD
index 4e6f43b862..10793eddc0 100644
--- a/testing/libibmad/APKBUILD
+++ b/testing/libibmad/APKBUILD
@@ -2,32 +2,30 @@
# Maintainer:
pkgname=libibmad
pkgver=1.3.13
-pkgrel=0
+pkgrel=1
pkgdesc="Generic InfiniBand MAD handling library"
-url="https://www.openfabrics.org/index.php/openfabrics-software.html"
+options="!check" # No testsuite
+url="https://www.openfabrics.org/downloads/management/"
arch="x86 x86_64 ppc64le"
-license="GPL-2.0 BSD"
+license="GPL-2.0-only OR BSD-2-Clause"
depends_dev="libibumad-dev"
makedepends="$depends_dev"
subpackages="$pkgname-dev"
source="https://www.openfabrics.org/downloads/management/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
-
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var
+ --localstatedir=/var \
+ --disable-static
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}