aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libieee1284
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2017-07-24 14:33:29 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-07-25 15:32:45 +0000
commit04a497c2453960d0add42b95639554542708790f (patch)
tree0156fcc03d81371d78640187f02e4f4e7ee6bfbd /testing/libieee1284
parentde53db70fee3ff4d2f58bd63908d221a1ae1b263 (diff)
downloadaports-04a497c2453960d0add42b95639554542708790f.tar.bz2
aports-04a497c2453960d0add42b95639554542708790f.tar.xz
testing/libieee1284: new aport
libieee1284 is a cross-platform library for parallel port access http://cyberelk.net/tim/libieee1284
Diffstat (limited to 'testing/libieee1284')
-rw-r--r--testing/libieee1284/APKBUILD48
-rw-r--r--testing/libieee1284/include.patch11
2 files changed, 59 insertions, 0 deletions
diff --git a/testing/libieee1284/APKBUILD b/testing/libieee1284/APKBUILD
new file mode 100644
index 0000000000..1728ae1d78
--- /dev/null
+++ b/testing/libieee1284/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Maintainer: Valery Kartel <valery.kartel@gmail.com>
+pkgname=libieee1284
+pkgver=0.2.11
+pkgrel=0
+pkgdesc="libieee1284 is a cross-platform library for parallel port access"
+url="http://cyberelk.net/tim/libieee1284"
+arch="all"
+options="!check"
+license="GPL2"
+depends=""
+depends_dev="py-$pkgname"
+makedepends="file python2-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc py-$pkgname:_py"
+source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2
+ include.patch"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+dev() {
+ default_dev || return 1
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+}
+
+_py() {
+ provides="py2-$pkgname"
+ depends="python2"
+ pkgdesc="$pkgdesc (python2 bindings)"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python2* "$subpkgdir"/usr/lib
+}
+
+sha512sums="06cc3049ce15613d34e39dc71bc572843c61ab64077c29ef9a6257edb0849c98565ff612a4cf787bc9642a39f1c89b7c47a20fb27f2318105be82aad8d472bb9 libieee1284-0.2.11.tar.bz2
+dccf1a78c02c6c1ea25eb3e054327298aac11972a32fafaa2180db31441f69cc1528bcb73127b7721776e946edee2344273d77443146bd707535bad148209453 include.patch"
diff --git a/testing/libieee1284/include.patch b/testing/libieee1284/include.patch
new file mode 100644
index 0000000000..ccacfcc8a9
--- /dev/null
+++ b/testing/libieee1284/include.patch
@@ -0,0 +1,11 @@
+--- a/src/access_io.c
++++ b/src/access_io.c
+@@ -50,7 +50,7 @@
+ #ifdef HAVE_LINUX
+
+ #ifdef HAVE_SYS_IO_H
+-#include <sys/io.h>
++#include "io.h"
+ #endif
+
+ #elif defined(HAVE_SOLARIS)