aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libkomparediff2
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-07-17 00:30:13 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-16 20:03:38 -0300
commit44cd23775b7ad848ccfc6a2199bdc18a058933f1 (patch)
tree11cd5ea7c7e964a1aa33b43f27a42068be1bc781 /testing/libkomparediff2
parent50c78e99694f4356391cc9f3b3a80fcf3e06c33c (diff)
downloadaports-44cd23775b7ad848ccfc6a2199bdc18a058933f1.tar.bz2
aports-44cd23775b7ad848ccfc6a2199bdc18a058933f1.tar.xz
testing/libkomparediff2: new aport
Diffstat (limited to 'testing/libkomparediff2')
-rw-r--r--testing/libkomparediff2/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/libkomparediff2/APKBUILD b/testing/libkomparediff2/APKBUILD
new file mode 100644
index 0000000000..787d33bf7b
--- /dev/null
+++ b/testing/libkomparediff2/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libkomparediff2
+pkgver=19.04.3
+pkgrel=0
+arch="all"
+url="https://kde.org/applications/development"
+pkgdesc="Library to compare files and strings"
+license="GPL-2.0-or-later AND LGPL-2.0-or-later"
+makedepends="extra-cmake-modules qt5-qtbase-dev kcoreaddons-dev kcodecs-dev kconfig-dev kxmlgui-dev ki18n-dev kio-dev"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="efac763b433956b05d83b20aa33afac19e696fc05ed7a03ab04a112b87516f92e7a750ba8d7b3a274662e05652700f1c8580f96aff7931e444c3cf2e2d49cf41 libkomparediff2-19.04.3.tar.xz"