aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libmustache
diff options
context:
space:
mode:
authorRenoir Boulanger <hello@renoirboulanger.com>2017-06-13 20:53:05 -0400
committerTimo Teräs <timo.teras@iki.fi>2017-08-29 07:48:33 +0000
commit893d39a018327fe132ad3bbe984d63a7f80b73a3 (patch)
tree241e7fe46551670e2cb5c058ebbd0c015473ab5b /testing/libmustache
parent05d9528df39f2655198341eb0da7a314208da3cd (diff)
downloadaports-893d39a018327fe132ad3bbe984d63a7f80b73a3.tar.bz2
aports-893d39a018327fe132ad3bbe984d63a7f80b73a3.tar.xz
testing/libmustache: new aport
https://github.com/jbboehr/libmustache C++ implementation of Mustache intended mainly for use as a PHP extension [TT: configure host]
Diffstat (limited to 'testing/libmustache')
-rw-r--r--testing/libmustache/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/libmustache/APKBUILD b/testing/libmustache/APKBUILD
new file mode 100644
index 0000000000..aca4b7843d
--- /dev/null
+++ b/testing/libmustache/APKBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Renoir Boulanger <hello@renoirboulanger.com>
+
+pkgname=libmustache
+_mustachespec_gitrev=b96be9fd4c6d6984828d93169fe7e86d8a8aec2f
+pkgver=0.4.3
+pkgrel=0
+pkgdesc="C++ implementation of Mustache intended mainly for use as a PHP extension"
+url="https://github.com/jbboehr/libmustache"
+arch=all
+license=MIT
+makedepends="autoconf automake libtool yaml-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jbboehr/${pkgname}/archive/v${pkgver}.tar.gz
+ mustache-spec-${_mustachespec_gitrev}.tar.gz::https://github.com/jbboehr/mustache-spec/archive/${_mustachespec_gitrev}.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ rm -rf "$builddir"/spec
+ ln -s "$srcdir"/mustache-spec-$_mustachespec_gitrev "$builddir"/spec
+ cd "$builddir"
+ autoreconf -fiv
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="864a6205bb128d95ecbb82806f526bbdb611d169f74e8cb25fae4e6ba3c36d52587316817ea092f494f140f41d1e70d9485bd10107847881ac56ad37b52fff05 libmustache-0.4.3.tar.gz
+9031df8459426bcc91dceb149b19c7e4397bdb08d80dbf175b536effe16ba1808f0a87be1a1f27997ef0b31d87d9c209dec167732e21abc8bd7f3e9982e6d262 mustache-spec-b96be9fd4c6d6984828d93169fe7e86d8a8aec2f.tar.gz"