aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libofx
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-09 07:13:15 -0300
committerprspkt <prspkt@protonmail.com>2019-05-11 20:45:17 +0300
commit968ddb097acd8122cf93060fa5b051b449f6962b (patch)
tree171449b378c8f4c3fdc41e74cf18ae23ac9f4d05 /testing/libofx
parent5f448bd97a3ed629b0584619bc60e49b77da0a86 (diff)
downloadaports-968ddb097acd8122cf93060fa5b051b449f6962b.tar.bz2
aports-968ddb097acd8122cf93060fa5b051b449f6962b.tar.xz
testing/libofx: upgrade to 0.9.14
Diffstat (limited to 'testing/libofx')
-rw-r--r--testing/libofx/APKBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/testing/libofx/APKBUILD b/testing/libofx/APKBUILD
index 8b362c9bfb..f78b871f7b 100644
--- a/testing/libofx/APKBUILD
+++ b/testing/libofx/APKBUILD
@@ -1,35 +1,35 @@
-# Contributor:
+# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: 7heo <7heo@mail.com>
pkgname=libofx
-pkgver=0.9.13
+pkgver=0.9.14
pkgrel=0
pkgdesc="The libofx OFX banking protocol abstraction library"
url="https://github.com/libofx/libofx"
arch="all"
-license="GPL-2.0"
-depends=""
+license="GPL-2.0-or-later"
makedepends="bash automake autoconf libtool gengetopt opensp-dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/libofx/$pkgname/archive/$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
-build() {
- cd "$builddir"
+prepare() {
+ default_prepare
./autogen.sh
+}
+
+build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var
+ --localstatedir=/var \
+ --disable-static
make -j1
}
package() {
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
}
-sha512sums="6a3d1791bfe4471a35dc52a367a072ece00645bb72a001c847dc01ce848a4f0562d00dd45c7e80573524cc2da2fa1a32a01dd84d793493268349b6fae1c63989 libofx-0.9.13.tar.gz"
+sha512sums="785c5130fc6f6cfc019d4aee2bf6de6311835e5dc7f2bd56a83f1ecf5e62ecb320a95bf4a5ff8f9e14dcaf5ff1eabc833cd7974927e571a8469c9a02fb8362d2 libofx-0.9.14.tar.gz"