aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libplacebo
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-27 17:45:35 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-28 22:34:24 -0300
commit26ebeb8357f6d736ba123227ea997b818a874439 (patch)
tree9de5a5a19369e79bf2bfeb192e364be5bd4ed17e /testing/libplacebo
parente54138a01164934b73923905f4f1707305e0f54c (diff)
downloadaports-26ebeb8357f6d736ba123227ea997b818a874439.tar.bz2
aports-26ebeb8357f6d736ba123227ea997b818a874439.tar.xz
testing/libplacebo: new aport
https://github.com/haasn/libplacebo Reusable library for GPU-accelerated video/image rendering
Diffstat (limited to 'testing/libplacebo')
-rw-r--r--testing/libplacebo/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/libplacebo/APKBUILD b/testing/libplacebo/APKBUILD
new file mode 100644
index 0000000000..0e30e3ff73
--- /dev/null
+++ b/testing/libplacebo/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=libplacebo
+pkgver=1.18.0
+pkgrel=0
+pkgdesc="Reusable library for GPU-accelerated video/image rendering"
+url="https://github.com/haasn/libplacebo"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="
+ meson
+ vulkan-loader-dev
+ glslang-static
+ glslang-dev
+ shaderc-dev
+ vulkan-headers
+ lcms2-dev
+ "
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/haasn/libplacebo/archive/v${pkgver}.tar.gz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ -Dvulkan=enabled \
+ -Dglslang=enabled \
+ -Dshaderc=enabled \
+ -Dtests=true \
+ -Dlcms=enabled \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="3115bbd019f4555340e64590e844de61a5fd4f02392b38a34d69059be79dcaeffc3d74b720568fb2f7f974409a8ff5feff83f7d6b7fdb2228af8761b78395339 libplacebo-1.18.0.tar.gz"