aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libpostal
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-07 22:47:05 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 21:58:37 -0300
commit2e3957b31d7e597603f257b63ae422160500213f (patch)
tree555f7d5bd3afedbf1e5c97928f267649c52d174a /testing/libpostal
parentc51cb9b6e53dea1be56c01c19526a458e23317b4 (diff)
downloadaports-2e3957b31d7e597603f257b63ae422160500213f.tar.bz2
aports-2e3957b31d7e597603f257b63ae422160500213f.tar.xz
testing/libpostal: fix building on non-x86 platforms
Diffstat (limited to 'testing/libpostal')
-rw-r--r--testing/libpostal/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/testing/libpostal/APKBUILD b/testing/libpostal/APKBUILD
index ae57cb2d5c..337876c402 100644
--- a/testing/libpostal/APKBUILD
+++ b/testing/libpostal/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.0.0
pkgrel=0
pkgdesc="A C library for parsing/normalizing street addresses around the world"
url="https://github.com/openvenues/libpostal"
-arch="x86_64 x86"
+arch="all"
license="MIT"
makedepends="autoconf automake libtool"
subpackages="$pkgname-static $pkgname-dev"
@@ -19,10 +19,17 @@ prepare() {
}
build() {
+ case "$CARCH" in
+ x86|x86_64) sse2="--enable-sse2" ;;
+ *) sse2="--disable-sse2";;
+ esac
+
./configure \
--prefix=/usr \
--datadir=/usr/local/share \
- --disable-data-download
+ --disable-data-download \
+ $sse2
+
make
}