aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libquotient/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-21 23:19:00 -0300
committerTBK <tbk@jjtc.eu>2019-05-22 15:02:37 +0200
commit5851a1d2592f6ccee47f3ed8fcc5730044db1c4a (patch)
treece2953d20d7b3805fba24dbee11f6c39c481921a /testing/libquotient/APKBUILD
parente08a203bb1b8603ad8b3ecc3f197f186117fe39c (diff)
downloadaports-5851a1d2592f6ccee47f3ed8fcc5730044db1c4a.tar.bz2
aports-5851a1d2592f6ccee47f3ed8fcc5730044db1c4a.tar.xz
testing/libquotient: rename from libqmatrixclient
Diffstat (limited to 'testing/libquotient/APKBUILD')
-rw-r--r--testing/libquotient/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/libquotient/APKBUILD b/testing/libquotient/APKBUILD
new file mode 100644
index 0000000000..747e482f15
--- /dev/null
+++ b/testing/libquotient/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=libqmatrixclient
+pkgver=0.5.1.2
+pkgrel=0
+pkgdesc="Qt5 library for cross-platform clients for Matrix"
+options="!check" # No testsuite
+url="https://github.com/QMatrixClient/libqmatrixclient"
+arch="all"
+license="LGPL-2.1-or-later"
+depends_dev="qt5-qtbase-dev qt5-qtmultimedia-dev"
+makedepends="$depends_dev cmake"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/QMatrixClient/libqmatrixclient/archive/${pkgver}.tar.gz"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DBUILD_SHARED_LIBS=1 \
+ -DQMATRIXCLIENT_INSTALL_EXAMPLE=0 \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="4e7cac3cc6a1ffc2a5a5ebf5c38dec72c3293f96b56d533838dea745a9b0de9a1ab14da666efcdad4f7d7a70279b922a0dbb3a3e26d1ad83f5b98d04fc9912a2 libqmatrixclient-0.5.1.2.tar.gz"