aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libquotient/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-21 23:27:00 -0300
committerTBK <tbk@jjtc.eu>2019-05-22 15:02:44 +0200
commitf7e2e46a7cf50c112fe2632da3dd3ca20d3b2711 (patch)
treecdf74ddb21154b229d63a864e27328d514d2cf06 /testing/libquotient/APKBUILD
parent5851a1d2592f6ccee47f3ed8fcc5730044db1c4a (diff)
downloadaports-f7e2e46a7cf50c112fe2632da3dd3ca20d3b2711.tar.bz2
aports-f7e2e46a7cf50c112fe2632da3dd3ca20d3b2711.tar.xz
testing/libquotient: upgrade to 0.5.2
Diffstat (limited to 'testing/libquotient/APKBUILD')
-rw-r--r--testing/libquotient/APKBUILD22
1 files changed, 17 insertions, 5 deletions
diff --git a/testing/libquotient/APKBUILD b/testing/libquotient/APKBUILD
index 747e482f15..15c82fbce6 100644
--- a/testing/libquotient/APKBUILD
+++ b/testing/libquotient/APKBUILD
@@ -1,17 +1,23 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Leo <thinkabit.ukim@gmail.com>
-pkgname=libqmatrixclient
-pkgver=0.5.1.2
+pkgname=libquotient
+_realname=libQuotient
+# Note that 0.5.x releases keep the old libqmatrix name
+# See https://github.com/quotient-im/libQuotient/releases/tag/0.5.2
+pkgver=0.5.2
pkgrel=0
pkgdesc="Qt5 library for cross-platform clients for Matrix"
options="!check" # No testsuite
-url="https://github.com/QMatrixClient/libqmatrixclient"
+url="https://github.com/quotient-im/libQuotient"
arch="all"
license="LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev qt5-qtmultimedia-dev"
makedepends="$depends_dev cmake"
subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/QMatrixClient/libqmatrixclient/archive/${pkgver}.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/quotient-im/$_realname/archive/${pkgver}.tar.gz"
+builddir="$srcdir/$_realname-$pkgver"
+provides="libqmatrixclient=$pkgver-r$pkgrel" # Rename compat
+replaces="libqmatrixclient" # Rename compat
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -33,4 +39,10 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="4e7cac3cc6a1ffc2a5a5ebf5c38dec72c3293f96b56d533838dea745a9b0de9a1ab14da666efcdad4f7d7a70279b922a0dbb3a3e26d1ad83f5b98d04fc9912a2 libqmatrixclient-0.5.1.2.tar.gz"
+dev() {
+ provides="libqmatrixclient-dev=$pkgver-r$pkgrel" # Rename compat
+ replaces="libqmatrixclient-dev" # Rename compat
+ default_dev
+}
+
+sha512sums="d1037139d62c41e35cd415e85ec8b7d3577af193e19a4307bcd65f83f43a54e015e4a888a0c26a266e41df613a329edd985e8935a9ea9d54f19662fdbfe55577 libquotient-0.5.2.tar.gz"