aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libressl
diff options
context:
space:
mode:
authorsystmkor <systmkor@gmail.com>2015-03-22 19:33:58 -0700
committerNatanael Copa <ncopa@alpinelinux.org>2015-03-24 15:50:09 +0000
commit16b40a900fe02bd0cad8521f95bc6b8b623fdf1e (patch)
treed8c1afb9f7c7b091ed7a8fd824ca7675f9a967c5 /testing/libressl
parentb3e00bb0c79884fa7dfdcc5c35a16928a3b513a7 (diff)
downloadaports-16b40a900fe02bd0cad8521f95bc6b8b623fdf1e.tar.bz2
aports-16b40a900fe02bd0cad8521f95bc6b8b623fdf1e.tar.xz
testing/libressl: new aport
FREE version of the SSL/TLS protocol forked from OpenSSL - Portable edition. http://www.libressl.org/
Diffstat (limited to 'testing/libressl')
-rw-r--r--testing/libressl/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/testing/libressl/APKBUILD b/testing/libressl/APKBUILD
new file mode 100644
index 0000000000..5cd035618d
--- /dev/null
+++ b/testing/libressl/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Orion <systmkor@gmail.com>
+# Maintainer: Orion <systmkor@gmail.com>
+#
+#
+pkgname=libressl
+pkgver=2.1.4
+pkgrel=0
+pkgdesc="FREE version of the SSL/TLS protocol forked from OpenSSL - Portable edition"
+url="http://www.libressl.org/"
+arch="all"
+license="openssl"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${pkgname}-${pkgver}.tar.gz"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="147105631f34f18047c19483410db384 libressl-2.1.4.tar.gz"
+sha256sums="e8e08535928774119a979412ee8e307444b7a1a42c8c47ac06ee09423ca9a04e libressl-2.1.4.tar.gz"
+sha512sums="534ac8cd438d2907025dcb7e24394e004058db33585d5aff3b594ea7494a866d05d5076f24836dcaf38e6fb27227019d55c26ed235f61da20a158c200f18c46e libressl-2.1.4.tar.gz"