aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libretro-hatari
diff options
context:
space:
mode:
authorDavid Demelier <markand@malikania.fr>2020-04-06 14:47:24 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-06 16:48:50 +0000
commitecf9b45e0cbe628b388eecfa71d02dd198cff0b2 (patch)
tree621f4a548ab650176c5bdcdd086d1b03aa4273cb /testing/libretro-hatari
parentf853a637320c9996d668f8c56b66970fe2097c13 (diff)
downloadaports-ecf9b45e0cbe628b388eecfa71d02dd198cff0b2.tar.bz2
aports-ecf9b45e0cbe628b388eecfa71d02dd198cff0b2.tar.xz
testing/libretro-hatari: new aport
https://github.com/libretro/hatari Atari ST/STE/TT/Falcon emulator for libretro
Diffstat (limited to 'testing/libretro-hatari')
-rw-r--r--testing/libretro-hatari/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/libretro-hatari/APKBUILD b/testing/libretro-hatari/APKBUILD
new file mode 100644
index 0000000000..163d9e07a7
--- /dev/null
+++ b/testing/libretro-hatari/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=libretro-hatari
+pkgver=0_git20200402
+pkgrel=0
+_commit="f8c35958ec1c93c32d41d61fa4903b2f5daec78c"
+pkgdesc="Atari ST/STE/TT/Falcon emulator for libretro"
+url="https://github.com/libretro/hatari"
+arch="all"
+license="GPL-2.0-only"
+makedepends="zlib-dev"
+source="$pkgname-$_commit.tar.gz::https://github.com/libretro/hatari/archive/$_commit.tar.gz"
+builddir="$srcdir/hatari-$_commit"
+options="!check" # No tests
+
+build() {
+ make -f Makefile.libretro
+}
+
+package() {
+ install -Dm644 hatari_libretro.so "$pkgdir"/usr/lib/libretro/hatari_libretro.so
+}
+
+sha512sums="c983adb31c361bb717015d0b1ea3e87e31e2fb8a3a3eb8b51827f91e777d9b93af7357ff2d0442bb2b3540ee26b340b4d0b9fc55e69bbf8126b18939dd4fac0c libretro-hatari-f8c35958ec1c93c32d41d61fa4903b2f5daec78c.tar.gz"