aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libretro-mupen64plus
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-07-09 14:56:31 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-09 20:51:47 -0300
commit361846824039b9e863e16de0bd2fef60da229c4c (patch)
tree587364d35e1a9e2fffc843d2370253b0e0634e17 /testing/libretro-mupen64plus
parent40bf81fe2c1814fcb224fbe3051f8231205f814a (diff)
downloadaports-361846824039b9e863e16de0bd2fef60da229c4c.tar.bz2
aports-361846824039b9e863e16de0bd2fef60da229c4c.tar.xz
testing/libretro-mupen64plus: new aport
Diffstat (limited to 'testing/libretro-mupen64plus')
-rw-r--r--testing/libretro-mupen64plus/APKBUILD37
-rw-r--r--testing/libretro-mupen64plus/musl-incompatibility.patch15
2 files changed, 52 insertions, 0 deletions
diff --git a/testing/libretro-mupen64plus/APKBUILD b/testing/libretro-mupen64plus/APKBUILD
new file mode 100644
index 0000000000..0c19a3b87a
--- /dev/null
+++ b/testing/libretro-mupen64plus/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=libretro-mupen64plus
+_pkgname=mupen64plus-libretro-nx
+pkgver=0_git20190625
+pkgrel=0
+_commit="b31459d1e9b1bc1cf93d3577e185fe8d4198a978"
+arch="x86_64 aarch64 ppc64le s390x" # Seems to be broken on non 64-bit platforms
+url="https://github.com/libretro/mupen64plus-libretro-nx"
+pkgdesc="libretro port of Mupen64 Plus with GLideN64"
+license="GPL-2.0-or-later"
+makedepends="mesa-dev zlib-dev libpng-dev nasm"
+source="$pkgname-$pkgver.tar.gz::https://github.com/libretro/$_pkgname/archive/$_commit.tar.gz
+ musl-incompatibility.patch"
+builddir="$srcdir/$_pkgname-$_commit"
+options="!check" # No tests
+
+build() {
+ case "$CARCH" in
+ x86)
+ WITH_DYNAREC=x86 make
+ ;;
+ x86_64)
+ WITH_DYNAREC=x86_64 make
+ ;;
+ armhf|armv7|aarch64)
+ WITH_DYNAREC=arm make
+ ;;
+ esac
+}
+
+package() {
+ install -Dm644 mupen64plus_next_libretro.so "$pkgdir"/usr/lib/libretro/mupen64plus_next_libretro.so
+}
+
+sha512sums="f098f2535404ce6703d0eab656c2d4799826e032870cc2f4cb59ec68f4f95b69e4300a9309e968eae0a856536d900a578b51f6f0093ed57e1d42b9ad271d4578 libretro-mupen64plus-0_git20190625.tar.gz
+8680a71cbecd1dfc30e1150d0cf258b20b928aa4eff341087a031c72459fc8a11415ebc5c8ff4fdd5b43915a6450f4dcad1aa9fb7ecbaceeed62aec3c45b5761 musl-incompatibility.patch"
diff --git a/testing/libretro-mupen64plus/musl-incompatibility.patch b/testing/libretro-mupen64plus/musl-incompatibility.patch
new file mode 100644
index 0000000000..27c5612c69
--- /dev/null
+++ b/testing/libretro-mupen64plus/musl-incompatibility.patch
@@ -0,0 +1,15 @@
+diff --git a/mupen64plus-core/src/device/r4300/new_dynarec/new_dynarec.c b/mupen64plus-core/src/device/r4300/new_dynarec/new_dynarec.c
+index 9fd6054..c6fe0f7 100644
+--- a/mupen64plus-core/src/device/r4300/new_dynarec/new_dynarec.c
++++ b/mupen64plus-core/src/device/r4300/new_dynarec/new_dynarec.c
+@@ -24,10 +24,8 @@
+ #include <string.h>
+ #include <assert.h>
+
+-#if defined(__APPLE__)
+ #include <sys/types.h> // needed for u_int, u_char, etc
+ #define MAP_ANONYMOUS MAP_ANON
+-#endif
+
+ #include "new_dynarec.h"
+ #include "api/m64p_types.h"