aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libseccomp
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-06-15 10:23:04 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2015-06-15 10:23:48 +0200
commit9ca764d6b9a7b7e47625dd4e153943fffb499d28 (patch)
tree14b291737535170b9eb8f831cb550b557ad6d476 /testing/libseccomp
parent1813645c6d415e7c242dfab93d6af6599e68be9e (diff)
downloadaports-9ca764d6b9a7b7e47625dd4e153943fffb499d28.tar.bz2
aports-9ca764d6b9a7b7e47625dd4e153943fffb499d28.tar.xz
testing/libseccomp: new aport
ref #3963
Diffstat (limited to 'testing/libseccomp')
-rw-r--r--testing/libseccomp/APKBUILD54
-rw-r--r--testing/libseccomp/remove-redefinition-prctl.patch10
2 files changed, 64 insertions, 0 deletions
diff --git a/testing/libseccomp/APKBUILD b/testing/libseccomp/APKBUILD
new file mode 100644
index 0000000000..12091d4465
--- /dev/null
+++ b/testing/libseccomp/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=libseccomp
+pkgver=2.2.1
+pkgrel=0
+pkgdesc="An interface to the Linux Kernel's syscall filtering mechanismf"
+url="https://github.com/seccomp/libseccomp"
+arch="all"
+license="LGPLv2.1"
+depends=""
+depends_dev=""
+makedepends="$depends_dev linux-headers"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/seccomp/libseccomp/releases/download/v$pkgver/libseccomp-$pkgver.tar.gz
+ remove-redefinition-prctl.patch"
+
+_builddir="$srcdir"/libseccomp-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="068af8e1bc36fcd4b326ee83875ab4fd libseccomp-2.2.1.tar.gz
+f10f467d772d6fcfbfb05e3bbba450b4 remove-redefinition-prctl.patch"
+sha256sums="0ba1789f54786c644af54cdffc9fd0dd0a8bb2b2ee153933f658855d2851a740 libseccomp-2.2.1.tar.gz
+e133750447fcf0f84504d7dff4a915e357cfce9961576c57fe63df669f8dc58a remove-redefinition-prctl.patch"
+sha512sums="da2347349ed723eadd096e088f78af82373d03ad383222375be5810004ee47e5f17314c8919eb1f7f5f10797a2fe7d846a206b33803d22be7cbd66c8e9cd9fdf libseccomp-2.2.1.tar.gz
+f2c31dcafdc9a1ad78e32e76b75e1c1603071eaa3f979e1f2483b879a34ad07e0a4ef3642196a695415cdf81e1ed2bf325175872fb4e203ef9d0e668c287493f remove-redefinition-prctl.patch"
diff --git a/testing/libseccomp/remove-redefinition-prctl.patch b/testing/libseccomp/remove-redefinition-prctl.patch
new file mode 100644
index 0000000000..2ea88fe057
--- /dev/null
+++ b/testing/libseccomp/remove-redefinition-prctl.patch
@@ -0,0 +1,10 @@
+--- ./src/system.c.orig
++++ ./src/system.c
+@@ -21,7 +21,6 @@
+
+ #include <stdlib.h>
+ #include <errno.h>
+-#include <sys/prctl.h>
+
+ #include <seccomp.h>
+