aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libsigrokdecode
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-11-04 11:52:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-05 15:35:34 +0000
commit171f6d33883ce50b656dc6b63ae6dec806b36c32 (patch)
tree68d42142b50c32b3660d673ce7aa8c1b7f279d62 /testing/libsigrokdecode
parentb5840473cc5177fef1bfd5c5ad5046c68545f41d (diff)
downloadaports-171f6d33883ce50b656dc6b63ae6dec806b36c32.tar.bz2
aports-171f6d33883ce50b656dc6b63ae6dec806b36c32.tar.xz
testing/libsigrokdecode: rebuild against python 3.8
and fix the .pc version
Diffstat (limited to 'testing/libsigrokdecode')
-rw-r--r--testing/libsigrokdecode/APKBUILD21
-rw-r--r--testing/libsigrokdecode/python3-embed.patch13
-rw-r--r--testing/libsigrokdecode/version.patch13
3 files changed, 40 insertions, 7 deletions
diff --git a/testing/libsigrokdecode/APKBUILD b/testing/libsigrokdecode/APKBUILD
index a0e1b5005d..417f7333d2 100644
--- a/testing/libsigrokdecode/APKBUILD
+++ b/testing/libsigrokdecode/APKBUILD
@@ -2,32 +2,39 @@
pkgname="libsigrokdecode"
pkgver=0.5.2
-pkgrel=0
+pkgrel=1
pkgdesc="A C library to decode protocol data captured by logic analyzers"
url="https://sigrok.org/wiki/Libsigrokdecode"
makedepends="glib-dev libserialport-dev libzip-dev libusb-dev libftdi1-dev
- glibmm-dev libsigrok-dev python3-dev check-dev"
+ glibmm-dev libsigrok-dev python3-dev check-dev
+ autoconf automake libtool"
depends=""
arch="all"
license="GPL-3.0-only"
-source="http://sigrok.org/download/source/$pkgname/$pkgname-$pkgver.tar.gz"
+source="http://sigrok.org/download/source/$pkgname/$pkgname-$pkgver.tar.gz
+ version.patch
+ python3-embed.patch"
subpackages="$pkgname-dev"
builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ default_prepare
+ autoreconf -vif
+}
+
build() {
- cd "${builddir}"
./configure --prefix=/usr/
make
}
check() {
- cd "${builddir}"
make check
}
package() {
- cd "${builddir}"
make DESTDIR="$pkgdir" install
}
-sha512sums="49d0cba3a5fe17593165c3669dc8530e4e68497369b461f39b63c903f41a3060766c23d44c4112c9b9a5e740ae1e2c03a735494ac798dc631f3913079be04e22 libsigrokdecode-0.5.2.tar.gz"
+sha512sums="49d0cba3a5fe17593165c3669dc8530e4e68497369b461f39b63c903f41a3060766c23d44c4112c9b9a5e740ae1e2c03a735494ac798dc631f3913079be04e22 libsigrokdecode-0.5.2.tar.gz
+6d8fa69a891b4333fe77213cf75df218090e58b51d6c92197351d95a977634f2228a63c9c0c75fcb1d816c59ee9eaf410d5e79827ac7c79b0784262ea0f9c3fd version.patch
+ab98ed3df3ad78fc19336a809c10ce00140ad4a389f31a6d05fe2122ee0698889a91c0711d57dc8d99ba888202f6dc9a10d485e473342298d94d3bccf52dbc99 python3-embed.patch"
diff --git a/testing/libsigrokdecode/python3-embed.patch b/testing/libsigrokdecode/python3-embed.patch
new file mode 100644
index 0000000000..eb856cd2a9
--- /dev/null
+++ b/testing/libsigrokdecode/python3-embed.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 56f01a2..c661c63 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -90,7 +90,7 @@ SR_PKG_CHECK_SUMMARY([srd_pkglibs_summary])
+
+ # Python 3 is always needed.
+ SR_PKG_CHECK([python3], [SRD_PKGLIBS],
+- [python3 >= 3.2], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2])
++ [python3-embed], [python3 >= 3.2], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2])
+ AS_IF([test "x$sr_have_python3" = xno],
+ [AC_MSG_ERROR([Cannot find Python 3 development headers.])])
+
diff --git a/testing/libsigrokdecode/version.patch b/testing/libsigrokdecode/version.patch
new file mode 100644
index 0000000000..7472542b4a
--- /dev/null
+++ b/testing/libsigrokdecode/version.patch
@@ -0,0 +1,13 @@
+diff --git a/m4/sigrok.m4 b/m4/sigrok.m4
+index 2ca2444..924b9df 100644
+--- a/m4/sigrok.m4
++++ b/m4/sigrok.m4
+@@ -54,7 +54,7 @@ m4_assert([$# >= 6])[]dnl
+ $1=$4
+ sr_git_deps=
+ # Check if we can get revision information from git.
+-sr_head=`git -C "$srcdir" rev-parse --verify --short HEAD 2>&AS_MESSAGE_LOG_FD`
++sr_head=`test -d "$srcdir"/.git && git -C "$srcdir" rev-parse --verify --short HEAD 2>&AS_MESSAGE_LOG_FD`
+
+ AS_IF([test "$?" = 0 && test "x$sr_head" != x], [dnl
+ test ! -f "$srcdir/.git/HEAD" \