aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libtorrent-rasterbar
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-07 03:35:15 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-08 20:06:24 -0300
commit162a926c68988a035c84866450ebbc32d380ba1a (patch)
tree18528c20dd76bd448c2f774dc070f55a654dde26 /testing/libtorrent-rasterbar
parent8102148bb4599832573b16b50da948cad9d52273 (diff)
downloadaports-162a926c68988a035c84866450ebbc32d380ba1a.tar.bz2
aports-162a926c68988a035c84866450ebbc32d380ba1a.tar.xz
testing/libtorrent-rasterbar: use py3 for python bindings
Diffstat (limited to 'testing/libtorrent-rasterbar')
-rw-r--r--testing/libtorrent-rasterbar/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/testing/libtorrent-rasterbar/APKBUILD b/testing/libtorrent-rasterbar/APKBUILD
index e7fea0031c..9b97897b08 100644
--- a/testing/libtorrent-rasterbar/APKBUILD
+++ b/testing/libtorrent-rasterbar/APKBUILD
@@ -2,17 +2,18 @@
# Maintainer: August Klein <amatcoder@gmail.com>
pkgname=libtorrent-rasterbar
pkgver=1.1.13
-pkgrel=0
+pkgrel=1
pkgdesc="Feature complete C++ bittorrent implementation"
-url="http://www.rasterbar.com/products/libtorrent"
+url="https://www.rasterbar.com/products/libtorrent"
arch="all"
license="BSD-3-Clause"
-depends_dev="boost-dev openssl-dev python2-dev"
+depends_dev="boost-dev openssl-dev python3-dev"
makedepends="$depends_dev linux-headers"
-subpackages="py2-$pkgname:_py2 $pkgname-static $pkgname-dev"
+subpackages="py3-$pkgname:_py3 $pkgname-static $pkgname-dev"
source="https://github.com/arvidn/libtorrent/releases/download/libtorrent-${pkgver//./_}/$pkgname-$pkgver.tar.gz"
build() {
+ PYTHON=/usr/bin/python3 \
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -22,11 +23,13 @@ build() {
--mandir=/usr/share/man \
--localstatedir=/var \
--enable-python-binding \
- --with-boost-system=boost_system
+ --with-boost-system=boost_python37
make
}
check() {
+ # Tests hang and timeout drone-ci on armv7
+ [ "$CARCH" = armv7 ] && return 0
make check
}
@@ -34,8 +37,8 @@ package() {
make DESTDIR="$pkgdir" install
}
-_py2() {
- pkgdesc="Python bindings for $pkgname"
+_py3() {
+ pkgdesc="Python3 bindings for $pkgname"
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}