aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libuniso
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-10-27 23:09:44 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-27 23:09:44 +0100
commit8da13e4bd035ba9613b40472760d4242d128709e (patch)
treebe089166909d81049361e60680fcd2a5012434e3 /testing/libuniso
parent578b727c8796a9a8669a219b042284b3d29cab6f (diff)
downloadaports-8da13e4bd035ba9613b40472760d4242d128709e.tar.bz2
aports-8da13e4bd035ba9613b40472760d4242d128709e.tar.xz
testing/libuniso: fix musl build
Diffstat (limited to 'testing/libuniso')
-rw-r--r--testing/libuniso/APKBUILD12
-rw-r--r--testing/libuniso/musl-missing-typesh.patch10
2 files changed, 19 insertions, 3 deletions
diff --git a/testing/libuniso/APKBUILD b/testing/libuniso/APKBUILD
index eb5de7b727..708fa14b1d 100644
--- a/testing/libuniso/APKBUILD
+++ b/testing/libuniso/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libuniso
pkgver=0.1
-pkgrel=0
+pkgrel=1
pkgdesc="Library to unpack files from CDROM (ISO-9660) images"
url="http://code.google.com/p/libuniso"
arch="all"
@@ -12,7 +12,8 @@ depends_dev=""
makedepends="lua-dev"
install=""
subpackages="$pkgname-dev lua-uniso:_lua"
-source="http://libuniso.googlecode.com/files/libuniso-$pkgver.tar.bz2"
+source="http://libuniso.googlecode.com/files/libuniso-$pkgver.tar.bz2
+ musl-missing-typesh.patch"
_builddir="$srcdir"/libuniso-$pkgver
prepare() {
@@ -44,4 +45,9 @@ _lua() {
mv "$pkgdir"/usr/lib/lua "$subpkgdir"/usr/lib/
}
-md5sums="9c1e65ceecce5786ff33c5dd82bea897 libuniso-0.1.tar.bz2"
+md5sums="9c1e65ceecce5786ff33c5dd82bea897 libuniso-0.1.tar.bz2
+e0948a860bbc3d93bfa7ebf25e0440ec musl-missing-typesh.patch"
+sha256sums="fc6a80200d6f8b20a99cd888cbcb0d55c8b45c5a3a6b540b99bbedb54a0248ad libuniso-0.1.tar.bz2
+9840e7c7a2d0459e8f7652d901b172de4fdcf6de46461b7c56fac127b3dda142 musl-missing-typesh.patch"
+sha512sums="dea27691b3e53bd6d7ff4c3530cb0e3d8c353bf03cbd7057910f37aa478fc95d66d4300a4dfa1c410957fafbce2d28e0b39a4e34928f6b0a562d3d6043e0f8e6 libuniso-0.1.tar.bz2
+56db43a674afc969f742524680eb02ae9685818022d4310ed8d1a6c727f5a185ccee9ed6553140b91403053311dd89a30d00602d4ee9d29bb3a96406d0462c95 musl-missing-typesh.patch"
diff --git a/testing/libuniso/musl-missing-typesh.patch b/testing/libuniso/musl-missing-typesh.patch
new file mode 100644
index 0000000000..098cbc46ce
--- /dev/null
+++ b/testing/libuniso/musl-missing-typesh.patch
@@ -0,0 +1,10 @@
+--- a/libuniso.c.orig
++++ b/libuniso.c
+@@ -30,6 +30,7 @@
+ #include <string.h>
+ #include <endian.h>
+ #include <sys/stat.h>
++#include <sys/types.h>
+
+ #include "uniso.h"
+