aboutsummaryrefslogtreecommitdiffstats
path: root/testing/liburing
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2020-02-08 14:02:54 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-11 01:48:14 -0300
commit6618ed5172dd27c2b8134d8932cc08d69c61b569 (patch)
tree2acf8f1ac851b28e931381b47b362aabc598e2d6 /testing/liburing
parent2fa73ad7aeea4ba5e48d853a1b84873a6b2a93fd (diff)
downloadaports-6618ed5172dd27c2b8134d8932cc08d69c61b569.tar.bz2
aports-6618ed5172dd27c2b8134d8932cc08d69c61b569.tar.xz
testing/liburing: new aport
https://git.kernel.dk/cgit/liburing/ Linux kernel io_uring access library
Diffstat (limited to 'testing/liburing')
-rw-r--r--testing/liburing/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/liburing/APKBUILD b/testing/liburing/APKBUILD
new file mode 100644
index 0000000000..9665b3f78c
--- /dev/null
+++ b/testing/liburing/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=liburing
+pkgver=0.3
+pkgrel=0
+pkgdesc="Linux kernel io_uring access library"
+url="https://git.kernel.dk/cgit/liburing/"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="linux-headers"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://git.kernel.dk/cgit/liburing/snapshot/liburing-$pkgver.tar.gz
+ "
+
+build() {
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="fb792f0d82b4ab8f95a3f4e3ae1b23c8f98d4345c7e0e4552334cc2dc70282efcfcec11d7ccf53f2cb36b3394c22d7265f220f774cba6fd4f922ae1e31173f81 liburing-0.3.tar.gz"