aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libutempter
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-13 23:25:59 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-13 23:25:59 -0300
commit9cc54a7d1cd69b6c19d0d5f3e86099d58bb614fd (patch)
treeb069764c57d1d1c0f347537095ea96e211c9b09b /testing/libutempter
parent131678683af6690f61abedc31fc6decb9189e52b (diff)
downloadaports-9cc54a7d1cd69b6c19d0d5f3e86099d58bb614fd.tar.bz2
aports-9cc54a7d1cd69b6c19d0d5f3e86099d58bb614fd.tar.xz
community/libutempter: move from testing
Diffstat (limited to 'testing/libutempter')
-rw-r--r--testing/libutempter/APKBUILD30
-rw-r--r--testing/libutempter/libutempter-remove-glibc-assumption.patch81
2 files changed, 0 insertions, 111 deletions
diff --git a/testing/libutempter/APKBUILD b/testing/libutempter/APKBUILD
deleted file mode 100644
index ee5f8d88c1..0000000000
--- a/testing/libutempter/APKBUILD
+++ /dev/null
@@ -1,30 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=libutempter
-pkgver=1.1.6
-pkgrel=0
-pkgdesc="Library interface to record user sessions in utmp/wtmp files"
-url="http://freecode.com/projects/libutempter"
-arch="all"
-license="LGPL-2.1"
-subpackages="$pkgname-dev $pkgname-doc"
-options="suid !check"
-pkggroups="utmp"
-source="ftp://ftp.altlinux.org/pub/people/ldv/utempter/$pkgname-$pkgver.tar.bz2
- libutempter-remove-glibc-assumption.patch"
-builddir="$srcdir/$pkgname-$pkgver"
-
-build() {
- cd "$builddir"
- make
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
- chown root:$pkggroups "$pkgdir/usr/lib/utempter/utempter"
- chmod 2755 "$pkgdir/usr/lib/utempter/utempter"
-}
-
-sha512sums="6ada410b981d157ae20b578de8ce20997ec0446ec6de6859549b080aa65976fc9900d211600dab09dc3d0d109daabad0994a648b093b8781b442ff26ca17fede libutempter-1.1.6.tar.bz2
-2d487a44ae3c84417f3dd55917ae707bee682b811ebe7aefe8b50aa9f309f879a7f9ed5cbce08119b6fea7dfddb97702348cfbb05ed45e79f95952d15f0366ff libutempter-remove-glibc-assumption.patch"
diff --git a/testing/libutempter/libutempter-remove-glibc-assumption.patch b/testing/libutempter/libutempter-remove-glibc-assumption.patch
deleted file mode 100644
index 6ed93355bb..0000000000
--- a/testing/libutempter/libutempter-remove-glibc-assumption.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-diff -Naur libutempter-1.1.6.orig/utempter.c libutempter-1.1.6/utempter.c
---- libutempter-1.1.6.orig/utempter.c 2010-11-04 13:14:53.000000000 -0400
-+++ libutempter-1.1.6/utempter.c 2014-06-20 16:37:09.762403323 -0400
-@@ -34,13 +34,7 @@
- #include <sys/stat.h>
- #include <utmp.h>
-
--#ifdef __GLIBC__
- # include <pty.h>
--#elif defined(__FreeBSD__)
--# include <libutil.h>
--#else
--# error Unsupported platform
--#endif /* __GLIBC__ || __FreeBSD__ */
-
- #define DEV_PREFIX "/dev/"
- #define DEV_PREFIX_LEN (sizeof(DEV_PREFIX)-1)
-@@ -106,17 +100,12 @@
-
- static int
- write_uwtmp_record(const char *user, const char *term, const char *host,
--#ifdef __GLIBC__
- pid_t pid,
--#endif
- int add)
- {
- struct utmp ut;
- struct timeval tv;
--
--#ifdef __GLIBC__
- size_t offset;
--#endif
-
- memset(&ut, 0, sizeof(ut));
-
-@@ -128,8 +117,6 @@
- if (host)
- strncpy(ut.ut_host, host, sizeof(ut.ut_host));
-
--#ifdef __GLIBC__
--
- offset = (strlen(term) <= sizeof(ut.ut_id)) ? 0 :
- strlen(term) - sizeof(ut.ut_id);
- strncpy(ut.ut_id, term + offset, sizeof(ut.ut_id));
-@@ -156,27 +143,6 @@
-
- (void) updwtmp(_PATH_WTMP, &ut);
-
--#elif defined(__FreeBSD__)
--
-- ut.ut_time = tv.tv_sec;
--
-- if (add)
-- {
-- login(&ut);
-- } else
-- {
-- if (logout(term) != 1)
-- {
--#ifdef UTEMPTER_DEBUG
-- fprintf(stderr, "utempter: logout: %s\n",
-- strerror(errno));
--#endif
-- exit(EXIT_FAILURE);
-- }
-- }
--
--#endif /* __GLIBC__ || __FreeBSD__ */
--
- #ifdef UTEMPTER_DEBUG
- fprintf(stderr,
- "utempter: DEBUG: utmp/wtmp record %s for terminal '%s'\n",
-@@ -255,8 +221,6 @@
- validate_device(device);
-
- return write_uwtmp_record(pw->pw_name, device + DEV_PREFIX_LEN, host,
--#ifdef __GLIBC__
- pid,
--#endif
- add);
- }