aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libva-utils
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-18 16:36:02 -0300
committerTBK <tbk@jjtc.eu>2019-05-25 04:11:03 +0200
commit8b62f5ad03d135d97f6b213311d0687429d5e221 (patch)
tree17e2d0abce42a9bd978ea6772d8800112cc500dc /testing/libva-utils
parent7348e0f79faad1ab5f8811d1e555620eae4e7868 (diff)
downloadaports-8b62f5ad03d135d97f6b213311d0687429d5e221.tar.bz2
aports-8b62f5ad03d135d97f6b213311d0687429d5e221.tar.xz
testing: remove duplicate dependencies and superfluous builddir statements
Closes: GH-7933
Diffstat (limited to 'testing/libva-utils')
-rw-r--r--testing/libva-utils/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/testing/libva-utils/APKBUILD b/testing/libva-utils/APKBUILD
index 64a50fd14a..34b074a53b 100644
--- a/testing/libva-utils/APKBUILD
+++ b/testing/libva-utils/APKBUILD
@@ -7,13 +7,11 @@ pkgdesc="Intel VA-API Media Applications and Scripts for libva"
url="https://github.com/01org/libva-utils"
arch="all"
license="MIT"
-makedepends="mesa-dev libva-dev autoconf automake libtool libva-dev"
+makedepends="mesa-dev libva-dev autoconf automake libtool"
source="https://github.com/01org/libva-utils/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2"
options="!check"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
./autogen.sh \
--build=$CBUILD \
--host=$CHOST \
@@ -26,13 +24,11 @@ build() {
make
}
-check(){
- cd "$builddir"
+check() {
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}