aboutsummaryrefslogtreecommitdiffstats
path: root/testing/linphone
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-07-18 14:56:02 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-07-18 14:56:02 +0000
commit2776a136bc85d85ff248eff3cb7104476f9c0815 (patch)
tree4291b7457cbdaf97224cccd9b58a9554d43a6456 /testing/linphone
parentef3402e5973de1a35a72fe8832a28d395e230aa8 (diff)
downloadaports-2776a136bc85d85ff248eff3cb7104476f9c0815.tar.bz2
aports-2776a136bc85d85ff248eff3cb7104476f9c0815.tar.xz
testing/linphone: fixes path for cmake files
Diffstat (limited to 'testing/linphone')
-rw-r--r--testing/linphone/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/linphone/APKBUILD b/testing/linphone/APKBUILD
index a7ccb26391..bfff2c1d2e 100644
--- a/testing/linphone/APKBUILD
+++ b/testing/linphone/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname="linphone"
pkgver="3.12.0"
-pkgrel=1
+pkgrel=2
pkgdesc="An opensource SIP phone for voice/video calls and instant messaging"
url="https://linphone.org/"
arch="all"
@@ -21,8 +21,7 @@ build() {
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_MODULE_PATH=/usr/lib/cmake \
- -DCMAKE_SKIP_INSTALL_RPATH=ON \
+ -DCMAKE_SKIP_BUILD_RPATH=ON \
-DENABLE_SHARED=YES \
-DENABLE_STATIC=NO \
-DENABLE_CONSOLE_UI=YES \
@@ -49,9 +48,14 @@ package() {
dev() {
default_dev
mkdir -p "$subpkgdir"/usr/lib/cmake/Linphone
- mv "$pkgdir"/usr/share/Linphone "$subpkgdir"/usr/lib/cmake/Linphone
mkdir -p "$subpkgdir"/usr/lib/cmake/LinphoneCxx
- mv "$pkgdir"/usr/share/LinphoneCxx "$subpkgdir"/usr/lib/cmake/LinphoneCxx
+ mv "$pkgdir"/usr/share/Linphone/cmake/* "$subpkgdir"/usr/lib/cmake/Linphone
+ mv "$pkgdir"/usr/share/LinphoneCxx/cmake/* "$subpkgdir"/usr/lib/cmake/LinphoneCxx
+ rmdir "$pkgdir"/usr/share/Linphone/cmake
+ rmdir "$pkgdir"/usr/share/LinphoneCxx/cmake
+
+ rmdir "$pkgdir"/usr/share/Linphone
+ rmdir "$pkgdir"/usr/share/LinphoneCxx
}
sounds() {