aboutsummaryrefslogtreecommitdiffstats
path: root/testing/linphone
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-04-14 22:36:34 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-04-16 06:31:07 +0000
commit25a7d574d417ca6d4117d9cbdcc4d8ffb57ce51d (patch)
tree6a250e86e890c86b2c45d4cd450e9666823c45e4 /testing/linphone
parent974f28618407d342e5a99baaf95b6a8a47111e6a (diff)
downloadaports-25a7d574d417ca6d4117d9cbdcc4d8ffb57ce51d.tar.bz2
aports-25a7d574d417ca6d4117d9cbdcc4d8ffb57ce51d.tar.xz
testing/linphone: upgrade to 4.3.1
Diffstat (limited to 'testing/linphone')
-rw-r--r--testing/linphone/APKBUILD41
1 files changed, 19 insertions, 22 deletions
diff --git a/testing/linphone/APKBUILD b/testing/linphone/APKBUILD
index 16abaab481..163b1e2803 100644
--- a/testing/linphone/APKBUILD
+++ b/testing/linphone/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname="linphone"
-pkgver="3.12.0"
-pkgrel=3
+pkgname=linphone
+pkgver=4.3.1
+pkgrel=0
pkgdesc="An opensource SIP phone for voice/video calls and instant messaging"
url="https://linphone.org/"
arch="all !mips !mips64" # blocked by belle-sip-dev
@@ -11,14 +11,13 @@ options="!check" # no test available
makedepends="cmake ortp-dev readline-dev sqlite-dev
bctoolbox-dev libxml2-dev zlib-dev libnotify-dev
speex-dev mediastreamer2-dev belle-sip-dev belcard-dev belr-dev
- libxv-dev v4l-utils-dev graphviz-dev doxygen sphinx
- py3-pystache py3-six"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-sounds:sounds:noarch"
-source="https://www.linphone.org/releases/sources/${pkgname}/${pkgname}-${pkgver}.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+ libxv-dev v4l-utils-dev graphviz-dev xerces-c-dev"
+subpackages="$pkgname-dev"
+source="https://gitlab.linphone.org/BC/public/liblinphone/-/archive/$pkgver/liblinphone-$pkgver.tar.gz"
+builddir="$srcdir/lib$pkgname-$pkgver"
build() {
- cmake \
+ cmake -B build\
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_SKIP_BUILD_RPATH=ON \
@@ -37,29 +36,27 @@ build() {
-DENABLE_GTK_UI=NO \
-DENABLE_ASSISTANT=NO \
-DENABLE_STRICT=NO \
- -DENABLE_ROOTCA_DOWNLOAD=NO .
- make
+ -DENABLE_ROOTCA_DOWNLOAD=NO \
+ -DENABLE_ADVANCED_IM=NO \
+ -DENABLE_DB_STORAGE=NO \
+ -DENABLE_LIME_X3DH=NO \
+ -DENABLE_UNIT_TESTS=NO \
+ -DENABLE_CXX_WRAPPER=NO \
+ -DENABLE_DOC=NO
+ make -C build
}
package() {
- make DESTDIR="$pkgdir" install
+ make -C build DESTDIR="$pkgdir" install
}
-dev() {
+dev() {
default_dev
mkdir -p "$subpkgdir"/usr/lib/cmake/Linphone
- mkdir -p "$subpkgdir"/usr/lib/cmake/LinphoneCxx
mv "$pkgdir"/usr/share/Linphone/cmake/* "$subpkgdir"/usr/lib/cmake/Linphone
- mv "$pkgdir"/usr/share/LinphoneCxx/cmake/* "$subpkgdir"/usr/lib/cmake/LinphoneCxx
# Fix includes
sed -i -e 's/INTERFACE_INCLUDE_DIRECTORIES.*/INTERFACE_INCLUDE_DIRECTORIES\ \"\/usr\/include\"/g' "$subpkgdir"/usr/lib/cmake/Linphone/LinphoneTargets.cmake
-
- # Remove empty dirs
- rmdir "$pkgdir"/usr/share/Linphone/cmake
- rmdir "$pkgdir"/usr/share/LinphoneCxx/cmake
- rmdir "$pkgdir"/usr/share/Linphone
- rmdir "$pkgdir"/usr/share/LinphoneCxx
}
sounds() {
@@ -70,4 +67,4 @@ sounds() {
rmdir "$pkgdir"/usr/share
}
-sha512sums="d4b8c9976c19c468e7c9c9be519840d67861b0d79f8d0d84404ed70cde43434a6be38128f80341862b9f5ec57809bce79060db58550cd8661b31cefe4c6633f0 linphone-3.12.0.tar.gz"
+sha512sums="5d47d947f9f9a5cf1a2484a8e6395bfb47bc9953a7833010dcd15939cb3fe019b47d2ea1c218cfc424dabf6b1015a01c085bcf68244e4fd73d4f741caf9ea979 liblinphone-4.3.1.tar.gz"