aboutsummaryrefslogtreecommitdiffstats
path: root/testing/linux-amlogic/add-phicomm-n1.patch
diff options
context:
space:
mode:
authorHe Yangxuan <yangxuan8282@gmail.com>2018-11-16 23:09:10 +0800
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-26 15:26:48 +0000
commit8dc0e43d5a410a6f173c14caaa625adaf45f11f4 (patch)
tree8818259554accdf24310ae8aef8a0ed4a06427d5 /testing/linux-amlogic/add-phicomm-n1.patch
parent9a88176c5408adb5321fa11300cb63e4dbea80ed (diff)
downloadaports-8dc0e43d5a410a6f173c14caaa625adaf45f11f4.tar.bz2
aports-8dc0e43d5a410a6f173c14caaa625adaf45f11f4.tar.xz
testing/linux-amlogic: new aport
This kernel package add support for Amlogic S9xxx device. Supported devices include many android box and some SBC like Odroid C2, Khadas Vim, Nanopi K2. This package based on mainline kernel, and apply some patches from mainline amlogic developer.
Diffstat (limited to 'testing/linux-amlogic/add-phicomm-n1.patch')
-rw-r--r--testing/linux-amlogic/add-phicomm-n1.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/testing/linux-amlogic/add-phicomm-n1.patch b/testing/linux-amlogic/add-phicomm-n1.patch
new file mode 100644
index 0000000000..2140d8d828
--- /dev/null
+++ b/testing/linux-amlogic/add-phicomm-n1.patch
@@ -0,0 +1,60 @@
+diff --git a/arch/arm64/boot/dts/amlogic/Makefile b/arch/arm64/boot/dts/amlogic/Makefile
+index 34dd0e9..773f415 100644
+--- a/arch/arm64/boot/dts/amlogic/Makefile
++++ b/arch/arm64/boot/dts/amlogic/Makefile
+@@ -17,6 +17,7 @@ dtb-$(CONFIG_ARCH_MESON) += meson-gxl-s905x-nexbox-a95x.dtb
+ dtb-$(CONFIG_ARCH_MESON) += meson-gxl-s905x-p212.dtb
+ dtb-$(CONFIG_ARCH_MESON) += meson-gxl-s905d-p230.dtb
+ dtb-$(CONFIG_ARCH_MESON) += meson-gxl-s905d-p231.dtb
++dtb-$(CONFIG_ARCH_MESON) += meson-gxl-s905d-phicomm-n1.dtb
+ dtb-$(CONFIG_ARCH_MESON) += meson-gxm-khadas-vim2.dtb
+ dtb-$(CONFIG_ARCH_MESON) += meson-gxm-nexbox-a1.dtb
+ dtb-$(CONFIG_ARCH_MESON) += meson-gxm-q200.dtb
+diff --git a/arch/arm64/boot/dts/amlogic/meson-gxl-s905d-phicomm-n1.dts b/arch/arm64/boot/dts/amlogic/meson-gxl-s905d-phicomm-n1.dts
+new file mode 100644
+index 0000000..7903dad
+--- /dev/null
++++ b/arch/arm64/boot/dts/amlogic/meson-gxl-s905d-phicomm-n1.dts
+@@ -0,0 +1,42 @@
++// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
++/*
++ * Copyright (c) 2018 He Yangxuan
++ */
++
++/dts-v1/;
++
++#include "meson-gxl-s905d-p230.dts"
++
++/ {
++ compatible = "phicomm,n1", "amlogic,s905d", "amlogic,meson-gxl";
++ model = "Phicomm N1";
++
++ aliases {
++ serial1 = &uart_A;
++ };
++
++ cvbs-connector {
++ status = "disabled";
++ };
++};
++
++&cvbs_vdac_port {
++ status = "disabled";
++};
++
++&external_phy {
++ /* Realtek RTL8211F (0x001cc916) */
++ eee-broken-1000t;
++};
++
++/* This is connected to the Bluetooth module: */
++&uart_A {
++ status = "okay";
++ pinctrl-0 = <&uart_a_pins>, <&uart_a_cts_rts_pins>;
++ pinctrl-names = "default";
++
++ bluetooth {
++ compatible = "brcm,bcm43438-bt";
++ shutdown-gpios = <&gpio GPIOX_17 GPIO_ACTIVE_HIGH>;
++ };
++};