aboutsummaryrefslogtreecommitdiffstats
path: root/testing/linux-sources/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-02-12 08:49:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-02-12 08:49:18 +0000
commita2e7b0043cd02246557d9743e4ca725ac0013b2e (patch)
tree2a5531972b9e758a2f539f6288aa02663df48915 /testing/linux-sources/APKBUILD
parent7206c19dfeb61905f3650a8df8703a6b9fdd7d39 (diff)
parent66101679ec75ef7f6c675b0edf1e3c10a484946c (diff)
downloadaports-a2e7b0043cd02246557d9743e4ca725ac0013b2e.tar.bz2
aports-a2e7b0043cd02246557d9743e4ca725ac0013b2e.tar.xz
Merge remote branch 'clandmeter/master'
Diffstat (limited to 'testing/linux-sources/APKBUILD')
-rw-r--r--testing/linux-sources/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/linux-sources/APKBUILD b/testing/linux-sources/APKBUILD
new file mode 100644
index 0000000000..63c1b47ac3
--- /dev/null
+++ b/testing/linux-sources/APKBUILD
@@ -0,0 +1,25 @@
+pkgname=linux-sources
+pkgver=2.6.28.4
+_kernver=2.6.28
+pkgrel=0
+pkgdesc="The vanilla Linux kernel sources"
+arch=i486
+license=GPL-2
+url=http://kernel.org
+source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
+ ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-$pkgver.bz2
+ "
+
+build() {
+ cd $srcdir/linux-$_kernver
+ if [ "$_kernver" != "$pkgver" ]; then
+ bunzip2 -c < ../patch-$pkgver.bz2 | patch -p1 || return 1
+ fi
+
+ mkdir -p "$pkgdir/usr/src"
+ cd "$srcdir"
+ mv "linux-$_kernver" "$pkgdir/usr/src/linux-$pkgver"
+}
+
+md5sums="d351e44709c9810b85e29b877f50968a linux-2.6.28.tar.bz2
+65afbbf63a73ee7be7227531622049fe patch-2.6.28.4.bz2"