aboutsummaryrefslogtreecommitdiffstats
path: root/testing/litespeed
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-11-07 11:24:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-07 16:46:16 +0000
commit022bcfe3740bce1a0377469cc734b962551f233f (patch)
tree3ea4c5254dbb2025a907747c413c0952335eb60a /testing/litespeed
parent9d5f4a336c3920dcc0fefb31bf53999bd79671ab (diff)
downloadaports-022bcfe3740bce1a0377469cc734b962551f233f.tar.bz2
aports-022bcfe3740bce1a0377469cc734b962551f233f.tar.xz
testing/litespeed: upgrade to 1.4.40
Diffstat (limited to 'testing/litespeed')
-rw-r--r--testing/litespeed/APKBUILD21
-rw-r--r--testing/litespeed/include.patch12
-rw-r--r--testing/litespeed/install.patch4
-rw-r--r--testing/litespeed/libressl.patch53
4 files changed, 24 insertions, 66 deletions
diff --git a/testing/litespeed/APKBUILD b/testing/litespeed/APKBUILD
index bd45c6541f..12c7ac250d 100644
--- a/testing/litespeed/APKBUILD
+++ b/testing/litespeed/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
pkgname=litespeed
-pkgver=1.4.28
-pkgrel=1
+pkgver=1.4.40
+pkgrel=0
_pkgreal=open$pkgname
_pkghome=var/lib/$pkgname
_php=php7
@@ -14,18 +14,18 @@ pkgusers=litespeed
pkggroups=litespeed
depends="$_php-$pkgname $_php-bcmath $_php-json $_php-mcrypt $_php-session"
depends_dev=
-makedepends="linux-headers libressl-dev geoip-dev expat-dev pcre-dev zlib-dev"
+makedepends="linux-headers openssl-dev geoip-dev expat-dev pcre-dev zlib-dev
+ bsd-compat-headers"
install="$pkgname.pre-install"
subpackages="$pkgname-snmp::noarch"
-source="http://open.litespeedtech.com/packages/$_pkgreal-$pkgver.tgz
+source="https://openlitespeed.org/packages/openlitespeed-$pkgver.src.tgz
$pkgname.initd
include.patch
install.patch
ls_lock.patch
thread.patch
- libressl.patch
"
-builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/openlitespeed-$pkgver"
build() {
cd "$builddir"
@@ -127,10 +127,9 @@ snmp() {
"$subpkgdir"/$_pkghome/add-ons
}
-sha512sums="caddf146bec216e06f7f7864d6cca712aba626e12a8cbf4fc6c2bf5e9bf277c035a0cbb24248c2140402bba604f075a0233aa50e133fe5205b4b7d2e2f6b3499 openlitespeed-1.4.28.tgz
+sha512sums="fb99beb724a8c324e37e1529267d9a5a57cb5f924896ba321f4f4781f77e18d689f6c77e162ab29951bf80633d20c867bd3453e6c61dd150b47071a92b80bd98 openlitespeed-1.4.40.src.tgz
2b0299246aaeb885122d8f939437f0e4701f6a79ea976f725ba8765d8b295c2797c0cac30e639d5eda665b9589710ee55acc4d03b078c4b9cc1e564994ccb9f5 litespeed.initd
-827425bb9f2e5daea8ef69f79747785a56c09a33837c381a961f798d1110f89629324531c028e0010a51aa0639ba5c6be81b80b10779a23ae7f1f84dd7b0b596 include.patch
-ead0ba0fabfb7d76a087f202d134bf86d909898e5d96e1330716c9288f21386d8b72f9caed34c095994a7ea328d7f8c9ae6d9e51a24e89b209099401ce09f2c5 install.patch
+5f45f665f8305d849ba58398700f83f4a9ded82b3b2445698ea5d12c3b7bfbb2cb55d0cfc13b6021326d140fbd84600503012e82d826f5767d8e4ee20f3ac912 include.patch
+4c8c3dc0624b7be30f25b5f25a9ab9890d6ffb101379b457e63e334cd42592eb1abef231506038ab6037040e7a98db02f00d6651547bd4a5f800c5ac671eba56 install.patch
2211e6c787700fc08eaee56f049c80690ef53d2b14cfcf17099ed0e5dfbd28b76a7b30f0c8814901e3c72bd4fc63732196b6fa0a8231cc10f86ba5130810b3d6 ls_lock.patch
-c7775836ee13b082e5c2ce011673b1a30b5ca83765d6d81ff1359110ba970808de6a87cd6d61fd688c9d2037451598154b429d70ad25094b9e9f10938aea00fd thread.patch
-189aa909a54c69ab12ba401a889d7d2507af7c651cd77fdd0fb4a811702b699a094aa150f20dc9f6d1566518a6b7d04a21ac43a81f1cb34f7eca82df9287b36d libressl.patch"
+c7775836ee13b082e5c2ce011673b1a30b5ca83765d6d81ff1359110ba970808de6a87cd6d61fd688c9d2037451598154b429d70ad25094b9e9f10938aea00fd thread.patch"
diff --git a/testing/litespeed/include.patch b/testing/litespeed/include.patch
index 29d055753d..3396e94c7d 100644
--- a/testing/litespeed/include.patch
+++ b/testing/litespeed/include.patch
@@ -20,3 +20,15 @@
#include <extensions/cgi/cgidworker.h>
#include <extensions/registry/extappregistry.h>
+diff --git a/src/sslpp/sslsesscache.h b/src/sslpp/sslsesscache.h
+index 4f8d061..edc1788 100644
+--- a/src/sslpp/sslsesscache.h
++++ b/src/sslpp/sslsesscache.h
+@@ -23,6 +23,7 @@
+ #include <util/tsingleton.h>
+ #include <stdint.h>
+ #include <unistd.h>
++#include <time.h>
+
+
+ #define LS_SSLSESSCACHE_DEFAULTSIZE 40*1024
diff --git a/testing/litespeed/install.patch b/testing/litespeed/install.patch
index 5b41b2eea5..89192af851 100644
--- a/testing/litespeed/install.patch
+++ b/testing/litespeed/install.patch
@@ -20,11 +20,11 @@
# Check whether --with-openssl was given.
--- a/dist/install.sh
+++ b/dist/install.sh
-@@ -35,11 +35,7 @@
+@@ -49,11 +49,7 @@
fi
if [ "x$OS" = "xLinux" ] ; then
-- if [ "x$OSTYPE" != "xx86_64" ] ; then
+- if [ "x$OSTYPE" != "x64" ] ; then
- $DLCMD $LSWS_HOME/admin/fcgi-bin/admin_php http://www.litespeedtech.com/packages/lsphp5_bin/i386/lsphp5
- else
- $DLCMD $LSWS_HOME/admin/fcgi-bin/admin_php http://www.litespeedtech.com/packages/lsphp5_bin/x86_64/lsphp5
diff --git a/testing/litespeed/libressl.patch b/testing/litespeed/libressl.patch
deleted file mode 100644
index c3476789a4..0000000000
--- a/testing/litespeed/libressl.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff --git a/src/sslpp/sslcontext.cpp b/src/sslpp/sslcontext.cpp
-index a701325..341b2da 100644
---- a/src/sslpp/sslcontext.cpp
-+++ b/src/sslpp/sslcontext.cpp
-@@ -723,7 +723,7 @@ int SslContext::enableSpdy(int level)
- #ifdef TLSEXT_TYPE_application_layer_protocol_negotiation
- SSL_CTX_set_alpn_select_cb(m_pCtx, SSLConntext_alpn_select_cb, this);
- #endif
--#ifdef TLSEXT_TYPE_next_proto_neg
-+#if defined(TLSEXT_TYPE_next_proto_neg) || defined(LIBRESSL_VERSION_NUMBER)
- SSL_CTX_set_next_protos_advertised_cb(m_pCtx,
- SslConnection_ssl_npn_advertised_cb, this);
- #else
-diff --git a/src/sslpp/sslutil.cpp b/src/sslpp/sslutil.cpp
-index 6561c04..afd9272 100644
---- a/src/sslpp/sslutil.cpp
-+++ b/src/sslpp/sslutil.cpp
-@@ -851,7 +851,16 @@ int SslUtil::getPrivateKeyPem(SSL_CTX *pCtx, AutoBuf *pBuf)
- {
- int ret = -1;
- BIO *pOut = BIO_new(BIO_s_mem());
-- EVP_PKEY *pKey = SSL_CTX_get0_privatekey(pCtx);
-+ EVP_PKEY *pKey = NULL;
-+#if OPENSSL_VERSION_NUMBER >= 0x10002000L && !defined(LIBRESSL_VERSION_NUMBER)
-+ pKey = SSL_CTX_get0_privatekey(pCtx);
-+#else
-+ SSL *ssl = SSL_new(pCtx);
-+ if (!ssl)
-+ return ret;
-+ pKey = SSL_get_privatekey(ssl);
-+ SSL_free(ssl);
-+#endif
-
- if (PEM_write_bio_PrivateKey(pOut, pKey, NULL, NULL, 0, NULL, NULL))
- ret = bioToBuf(pOut, pBuf);
-@@ -863,7 +872,16 @@ int SslUtil::getCertPem(SSL_CTX *pCtx, AutoBuf *pBuf)
- {
- int ret = -1;
- BIO *pOut = BIO_new(BIO_s_mem());
-- X509 *pCert = SSL_CTX_get0_certificate(pCtx);
-+ X509 *pCert = NULL;
-+#if OPENSSL_VERSION_NUMBER >= 0x10002000L && !defined(LIBRESSL_VERSION_NUMBER)
-+ pCert = SSL_CTX_get0_certificate(pCtx);
-+#else
-+ SSL *ssl = SSL_new(pCtx);
-+ if (!ssl)
-+ return ret;
-+ pCert = SSL_get_certificate(ssl);
-+ SSL_free(ssl);
-+#endif
-
- if (PEM_write_bio_X509(pOut, pCert))
- ret = bioToBuf(pOut, pBuf);