aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lldb
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-06-07 16:23:31 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-16 05:38:31 -0300
commited4dc0abbc71535056a9408687b9c3e3d9a0801f (patch)
treeb0f021e12339d8905683c7b025ab7f13a5fbb50e /testing/lldb
parenteaa0c0a23b089999372d86e7dc5bbcde4b2c094a (diff)
downloadaports-ed4dc0abbc71535056a9408687b9c3e3d9a0801f.tar.bz2
aports-ed4dc0abbc71535056a9408687b9c3e3d9a0801f.tar.xz
testing/lldb: upgrade to 8.0.0
Diffstat (limited to 'testing/lldb')
-rw-r--r--testing/lldb/APKBUILD25
-rw-r--r--testing/lldb/cmake-include-ClangConfig.patch8
-rw-r--r--testing/lldb/musl-include-ptrace.aarch64.patch17
3 files changed, 13 insertions, 37 deletions
diff --git a/testing/lldb/APKBUILD b/testing/lldb/APKBUILD
index a37b2f96d0..d3b6c594d9 100644
--- a/testing/lldb/APKBUILD
+++ b/testing/lldb/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
-# Maintainer:
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=lldb
# Note: Update together with llvm.
-pkgver=5.0.2
+pkgver=8.0.0
pkgrel=0
_vermajor=${pkgver%%.*}
pkgdesc="Next generation, high-performance debugger"
@@ -25,11 +25,10 @@ makedepends="
python2-dev
swig
"
-subpackages="$pkgname-dev py2-$pkgname:py2"
+subpackages="$pkgname-static $pkgname-dev py2-$pkgname:py2"
source="https://releases.llvm.org/$pkgver/$pkgname-$pkgver.src.tar.xz
- musl-include-ptrace.aarch64.patch
- cmake-include-ClangConfig.patch
fix-embedded_interpreter.patch
+ cmake-include-ClangConfig.patch
"
builddir="$srcdir/$pkgname-$pkgver.src"
@@ -45,6 +44,8 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DLLVM_LINK_LLVM_DYLIB=ON \
-DLLDB_DISABLE_LIBEDIT=ON \
+ -DLLDB_TEST_C_COMPILER=clang \
+ -DLLDB_TEST_CXX_COMPILER=clang++ \
-DPYTHON_EXECUTABLE=/usr/bin/python2
ninja
}
@@ -53,13 +54,6 @@ package() {
cd "$builddir"/build
DESTDIR="$pkgdir" ninja install
-
- # XXX: I have no idea why this is installed to bindir. Moving it to
- # libdir may break it, but I don't know how to test this.
- mv "$pkgdir"/usr/bin/liblldb-intel-mpxtable.so "$pkgdir"/usr/lib/ || true
-
- # Remove static libraries.
- rm -f "$pkgdir"/usr/lib/*.a
}
py2() {
@@ -83,7 +77,6 @@ py2() {
python2 -m compileall -fqd /$sitedir $sitedir
}
-sha512sums="66eaaead60cc908ac061bedb4fac9cb96cecb7f4e5a79a51b6fa080e8f61f718b14e5f3581ead832b495bf10f055d4253d199236a0947dd22395ec80bf2afcf4 lldb-5.0.2.src.tar.xz
-1613a1cb042edd430aba6b86e4971ebb01f7d2bc3f13a5a1264cb94da7612188897e9dcaaa9233be8af5c8f4bad013dd0cfb821e323cd73dfe07fe125869ccef musl-include-ptrace.aarch64.patch
-18ea4cd3ef357299833e243613031ad67ff82f7c93c1f3fbe2cbce8876ffeec2d8ff2f94c8242ea540c2604ffbc023fb2678643fc9d3b64231f096054d186aef cmake-include-ClangConfig.patch
-3c611fa5d45b6cb3f2925a31deeb8a34c295277aedcd55c22851d373897acd376fa92f4ef953c96a25c8dae4c93b6a88de0918550672141d324a3813d8283d48 fix-embedded_interpreter.patch"
+sha512sums="5192d6d6d1759db28569de929ba8db2a80283000f1bf8453d9cf172ac85574c8eacc13f9fe64ecabea0533bfc49c0f58ea8fb29b1f4d88c065d905d553f2e60c lldb-8.0.0.src.tar.xz
+3c611fa5d45b6cb3f2925a31deeb8a34c295277aedcd55c22851d373897acd376fa92f4ef953c96a25c8dae4c93b6a88de0918550672141d324a3813d8283d48 fix-embedded_interpreter.patch
+0edf6e750cd9367fccb32636c37b3d21bb781173b182b8e4b537c19c1b49898f792a3fa8139e50129af4570736e6dcda6bf390357b367c1f00179fc2b0fb6d62 cmake-include-ClangConfig.patch"
diff --git a/testing/lldb/cmake-include-ClangConfig.patch b/testing/lldb/cmake-include-ClangConfig.patch
index 96fd332b64..7b93d8e657 100644
--- a/testing/lldb/cmake-include-ClangConfig.patch
+++ b/testing/lldb/cmake-include-ClangConfig.patch
@@ -10,14 +10,14 @@ This fixes the following build error:
clang-5.0: error: linker command failed with exit code 1 (use -v to see invocation)
See https://github.com/alpinelinux/aports/pull/2342 for more information.
-
---- a/cmake/modules/LLDBStandalone.cmake
+--- a/cmake/modules/LLDBStandalone.cmake.orig
+++ b/cmake/modules/LLDBStandalone.cmake
-@@ -100,6 +100,7 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
+@@ -101,6 +101,7 @@
# Import CMake library targets from LLVM and Clang.
include("${LLVM_OBJ_ROOT}/lib${LLVM_LIBDIR_SUFFIX}/cmake/llvm/LLVMConfig.cmake")
+ include("/usr/lib/cmake/clang/ClangConfig.cmake")
- # cmake/clang/ClangConfig.cmake is not created when LLVM and Cland are built together.
if (EXISTS "${LLVM_OBJ_ROOT}/lib${LLVM_LIBDIR_SUFFIX}/cmake/clang/ClangConfig.cmake")
include("${LLVM_OBJ_ROOT}/lib${LLVM_LIBDIR_SUFFIX}/cmake/clang/ClangConfig.cmake")
+ endif()
+
diff --git a/testing/lldb/musl-include-ptrace.aarch64.patch b/testing/lldb/musl-include-ptrace.aarch64.patch
deleted file mode 100644
index f6ec2cc34b..0000000000
--- a/testing/lldb/musl-include-ptrace.aarch64.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-From: Jakub Jirutka <jakub@jirutka.cz>
-Date: Mon, 29 Aug 2016 00:18:00 +0200
-Subject: [PATCH] Fix compile error on aarch64
-
-NativeRegisterContextLinux_arm64 uses user_pt_regs and user_fpsimd_state
-which are defined in asm/ptrace.h.
-
---- a/source/Plugins/Process/Linux/NativeRegisterContextLinux_arm64.cpp
-+++ b/source/Plugins/Process/Linux/NativeRegisterContextLinux_arm64.cpp
-@@ -29,6 +29,7 @@
-
- // System includes - They have to be included after framework includes because they define some
- // macros which collide with variable names in other modules
-+#include <asm/ptrace.h>
- #include <sys/socket.h>
- // NT_PRSTATUS and NT_FPREGSET definition
- #include <elf.h>