aboutsummaryrefslogtreecommitdiffstats
path: root/testing/llmnrd
diff options
context:
space:
mode:
authorNathan Caldwell <saintdev@gmail.com>2018-11-22 16:14:33 -0700
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-17 10:53:55 +0000
commit52900811aa9f2aef29ef5d0e2409cca5e7335e84 (patch)
treed6558f7093bce3c15a8e50f9b1461ecdcf021549 /testing/llmnrd
parentbfd1c6d344629a380f789e85d8d80edda6ede096 (diff)
downloadaports-52900811aa9f2aef29ef5d0e2409cca5e7335e84.tar.bz2
aports-52900811aa9f2aef29ef5d0e2409cca5e7335e84.tar.xz
testing/llmnrd: new aport
https://github.com/tklauser/llmnrd Link-Local Multicast Resolution (LLMNR) Daemon
Diffstat (limited to 'testing/llmnrd')
-rw-r--r--testing/llmnrd/APKBUILD34
-rw-r--r--testing/llmnrd/llmnrd.initd12
2 files changed, 46 insertions, 0 deletions
diff --git a/testing/llmnrd/APKBUILD b/testing/llmnrd/APKBUILD
new file mode 100644
index 0000000000..89d395bfcb
--- /dev/null
+++ b/testing/llmnrd/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Nathan Caldwell <saintdev@gmail.com>
+# Maintainer: Nathan Caldwell <saintdev@gmail.com>
+pkgname=llmnrd
+pkgver=0.5
+pkgrel=0
+pkgdesc="Link-Local Multicast Resolution (LLMNR) Daemon for Linux"
+url="https://github.com/tklauser/llmnrd"
+arch="all"
+license="GPL-2.0-only"
+depends=""
+makedepends="linux-headers"
+subpackages="$pkgname-doc $pkgname-openrc"
+# llmnrd has no test suite
+options="!check"
+source="https://github.com/tklauser/llmnrd/releases/download/v$pkgver/llmnrd-$pkgver.tar.bz2
+ llmnrd.initd
+ "
+builddir="$srcdir/llmnrd-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make prefix=/usr DESTDIR="$pkgdir" install
+
+ install -m755 -D "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname
+}
+
+sha512sums="e7d179bf7c0417974e39c225957f17d57a4bb00fcc74d0e3c66a05b9da2f88928f2867624b9f9193a4438be4d658bfe8474fd7fa637feaa5a406df5f98e8074e llmnrd-0.5.tar.bz2
+393643c9a051aeb3ba283bfe2845c0480b0eba93ef89705ef9e3162a7ecff37d1733ab16482b6be09d89eed263a9c83323762c6dbc573b7a94c8a7cbfd1d10ef llmnrd.initd"
diff --git a/testing/llmnrd/llmnrd.initd b/testing/llmnrd/llmnrd.initd
new file mode 100644
index 0000000000..fdf48a73e3
--- /dev/null
+++ b/testing/llmnrd/llmnrd.initd
@@ -0,0 +1,12 @@
+#!/sbin/openrc-run
+
+name=llmnrd
+command="/usr/sbin/llmnrd"
+command_background="yes"
+
+pidfile="/run/$name.pid"
+
+depend() {
+ need net
+ after firewall
+}