aboutsummaryrefslogtreecommitdiffstats
path: root/testing/llvm6
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2019-03-19 16:44:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-03-20 20:24:44 +0000
commit5c367a82c221439f1f987bc283f4f4ba98c95a0c (patch)
tree252da5ab7bacf9a976207cca7991b8a9fc2d450a /testing/llvm6
parent13948dbdd450ed5d1897baee6fe5f7d6408593ff (diff)
downloadaports-5c367a82c221439f1f987bc283f4f4ba98c95a0c.tar.bz2
aports-5c367a82c221439f1f987bc283f4f4ba98c95a0c.tar.xz
testing/llvm6: fix test failure on ppc64le and re-enable
Diffstat (limited to 'testing/llvm6')
-rw-r--r--testing/llvm6/APKBUILD6
-rw-r--r--testing/llvm6/fix-memory-mf_exec-on-aarch64.patch2
2 files changed, 4 insertions, 4 deletions
diff --git a/testing/llvm6/APKBUILD b/testing/llvm6/APKBUILD
index 67c293b71c..9a66c1888a 100644
--- a/testing/llvm6/APKBUILD
+++ b/testing/llvm6/APKBUILD
@@ -6,9 +6,9 @@ _pkgname=llvm
pkgver=6.0.1
_majorver=${pkgver%%.*}
pkgname=$_pkgname$_majorver
-pkgrel=0
+pkgrel=1
pkgdesc="Low Level Virtual Machine compiler system, version $_majorver"
-arch="all !ppc64le"
+arch="all"
url="https://llvm.org/"
license="UOI-NCSA"
depends_dev="$pkgname=$pkgver-r$pkgrel"
@@ -254,5 +254,5 @@ sha512sums="cbbb00eb99cfeb4aff623ee1a5ba075e7b5a76fc00c5f9f539ff28c108598f5708a0
6d1a716e5aa24e6b9a3acf4cc11e2504b1b01abf574074e9e5617b991de87d5e4e687eb18e85e73d5e632568afe2fc357771c4c96f9e136502071991496fb78c cmake-fix-libLLVM-name.patch
49c47f125014b60d0ea7870f981a2c1708ad705793f89287ed846ee881a837a4dc0170bf467e03f2ef56177473128945287749ac80dc2d13cfabcf8b929ba58a disable-FileSystemTest.CreateDir-perms-assert.patch
695502bd3b5454c2f5630c59a8cf5f8aeb0deac16a76a8a4df34849e1e35c12ed4234572a320fe4c7e96f974f572f429eb816c5aa3dcfb17057f550eac596495 0001-Disable-dynamic-lib-tests-for-musl-s-dlclose-is-noop.patch
-e6d925ddc71f9f2ce8a859ac519dad51cba99c07129e378a5388bb1dd2f7d5b9d5ed392e85267fd20043789c7460a7d705eb8f970b2d130edbf5a934e9505ac4 fix-memory-mf_exec-on-aarch64.patch
+c9ef3cd95c4bd1d6ac69bbcd471b01755126d00f59d27d4a2a2ef5623943be73f8407e2fd731294d1a9d81a66e459f45f3f1d5dc5f9646f4f2fb2d8d891b5279 fix-memory-mf_exec-on-aarch64.patch
7d4825d16107e56a14b7b05be847f03d75e2e05952bea0742a1233b5b0441c9934d8058e612abb6471272884372d9bfd3348355fbd3c19cba82a554003cc3eec fix-LLVMConfig-cmake-install-prefix.patch"
diff --git a/testing/llvm6/fix-memory-mf_exec-on-aarch64.patch b/testing/llvm6/fix-memory-mf_exec-on-aarch64.patch
index 644c77790a..a70b397333 100644
--- a/testing/llvm6/fix-memory-mf_exec-on-aarch64.patch
+++ b/testing/llvm6/fix-memory-mf_exec-on-aarch64.patch
@@ -19,7 +19,7 @@ Upstream-Issue: https://bugs.llvm.org/show_bug.cgi?id=14278#c10
return PROT_READ | PROT_WRITE | PROT_EXEC;
case llvm::sys::Memory::MF_EXEC:
-#if defined(__FreeBSD__)
-+#if defined(__FreeBSD__) || (defined(__linux__) && defined(__aarch64__))
++#if defined(__FreeBSD__) || (defined(__linux__) && (defined(__aarch64__) || defined(__powerpc64__)))
// On PowerPC, having an executable page that has no read permission
// can have unintended consequences. The function InvalidateInstruction-
// Cache uses instructions dcbf and icbi, both of which are treated by