aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lokalize/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-07-17 00:42:13 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-16 20:03:05 -0300
commit50c78e99694f4356391cc9f3b3a80fcf3e06c33c (patch)
tree32043f671cf0f31a2f6c832187f14828fbef8663 /testing/lokalize/APKBUILD
parent15c401febccaade966749c281738dbcaf58f6b3b (diff)
downloadaports-50c78e99694f4356391cc9f3b3a80fcf3e06c33c.tar.bz2
aports-50c78e99694f4356391cc9f3b3a80fcf3e06c33c.tar.xz
testing/lokalize: new aport
Diffstat (limited to 'testing/lokalize/APKBUILD')
-rw-r--r--testing/lokalize/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/lokalize/APKBUILD b/testing/lokalize/APKBUILD
new file mode 100644
index 0000000000..5d5256a3b7
--- /dev/null
+++ b/testing/lokalize/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=lokalize
+pkgver=19.04.3
+pkgrel=0
+arch="all"
+url="https://kde.org/applications/office/org.kde.lokalize"
+pkgdesc="Computer-Aided Translation System"
+license="(GPL-2.0-only OR GPL-3.0-only) AND GFDL-1.2-only"
+makedepends="extra-cmake-modules qt5-qtbase-dev ki18n-dev kio-dev kxmlgui-dev knotifications-dev kconfig-dev kcoreaddons-dev kdoctools-dev kross-dev sonnet-dev kdbusaddons-dev kcrash-dev hunspell-dev"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+options="!check" # No tests
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="66f4cf4c103ef7888f762e202b2ec53fcb653f2208ff078c9b755038bfb4e1f34b80455ba6dc77c39ac864bacdcfec3f88ad6c9df5d1dfd1fb485cb1395b7207 lokalize-19.04.3.tar.xz"