aboutsummaryrefslogtreecommitdiffstats
path: root/testing/loksh
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2015-08-09 00:11:31 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-08-10 15:22:33 +0200
commit5bc39a7221e1a760864bf5bf409ba60ea3d494c3 (patch)
tree677e100ed8ecf91e8cf1f5f34a3704d902621b95 /testing/loksh
parent842e258a6130f64204f20ca8172946f5f26fa1e2 (diff)
downloadaports-5bc39a7221e1a760864bf5bf409ba60ea3d494c3.tar.bz2
aports-5bc39a7221e1a760864bf5bf409ba60ea3d494c3.tar.xz
testing/loksh: new aport
Diffstat (limited to 'testing/loksh')
-rw-r--r--testing/loksh/APKBUILD31
-rw-r--r--testing/loksh/loksh.post-install3
l---------testing/loksh/loksh.post-upgrade1
-rw-r--r--testing/loksh/loksh.pre-deinstall3
4 files changed, 38 insertions, 0 deletions
diff --git a/testing/loksh/APKBUILD b/testing/loksh/APKBUILD
new file mode 100644
index 0000000000..e4fec4b7f1
--- /dev/null
+++ b/testing/loksh/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=loksh
+pkgver=5.7
+pkgrel=0
+pkgdesc="A Linux port of OpenBSD's ksh"
+url="https://github.com/dimkr/$pkgname"
+arch="all"
+license="ISC"
+replaces="oksh"
+depends=""
+makedepends="musl"
+install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
+subpackages="$pkgname-doc"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/dimkr/$pkgname/archive/5.7.tar.gz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+build() {
+ make -C "$_builddir" || return 1
+}
+
+package() {
+ make DESTDIR="$pkgdir" PREFIX="/usr" \
+ -C "$_builddir" install || return 1
+
+ mkdir -p "$pkgdir"/bin
+ mv "$pkgdir"/usr/bin/ksh "$pkgdir"/bin || return 1
+}
+
+md5sums="aa26163fda0a9ca77556473e79981300 loksh-5.7.tar.gz"
+sha256sums="4bca639cd0f9be61996619d10e523a9dc07cebc7ae60bd4889763eb08ee8ac6e loksh-5.7.tar.gz"
+sha512sums="87be684504c38fc3543d3f50861b8fc3d854c20b56d3066e620af9a8892893a4ecf9105c0c54446bdc3ede5bc76da42ca0d50b83f042257ee31276898b0d42ae loksh-5.7.tar.gz"
diff --git a/testing/loksh/loksh.post-install b/testing/loksh/loksh.post-install
new file mode 100644
index 0000000000..0844ccf68b
--- /dev/null
+++ b/testing/loksh/loksh.post-install
@@ -0,0 +1,3 @@
+#!/bin/sh
+add-shell '/bin/ksh'
+exit 0
diff --git a/testing/loksh/loksh.post-upgrade b/testing/loksh/loksh.post-upgrade
new file mode 120000
index 0000000000..9c69b08659
--- /dev/null
+++ b/testing/loksh/loksh.post-upgrade
@@ -0,0 +1 @@
+loksh.post-install \ No newline at end of file
diff --git a/testing/loksh/loksh.pre-deinstall b/testing/loksh/loksh.pre-deinstall
new file mode 100644
index 0000000000..2a4b7d83cd
--- /dev/null
+++ b/testing/loksh/loksh.pre-deinstall
@@ -0,0 +1,3 @@
+#!/bin/sh
+remove-shell '/bin/ksh'
+exit 0