aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lshell
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-09 12:46:29 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-09 12:46:29 -0300
commit36ebbcebacfcf866672f8472e7334ae94c7314f6 (patch)
tree6035b09ae8b55f0ea098fefed56e619bb380d6d3 /testing/lshell
parent020ee9a3a8b48571172ebe432d99c88e81a69af9 (diff)
downloadaports-36ebbcebacfcf866672f8472e7334ae94c7314f6.tar.bz2
aports-36ebbcebacfcf866672f8472e7334ae94c7314f6.tar.xz
testing/lshell: use python3
Diffstat (limited to 'testing/lshell')
-rw-r--r--testing/lshell/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/testing/lshell/APKBUILD b/testing/lshell/APKBUILD
index 69a17d02eb..5b64c47cf7 100644
--- a/testing/lshell/APKBUILD
+++ b/testing/lshell/APKBUILD
@@ -2,22 +2,22 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=lshell
pkgver=0.9.18
-pkgrel=3
-pkgdesc="Python-based limited Shell"
+pkgrel=4
+pkgdesc="Python3-based limited Shell"
url="https://github.com/ghantoos/lshell"
arch="noarch"
license="GPL-3.0-or-later"
-depends="python2"
-makedepends="py-setuptools"
+depends="python3"
+makedepends="py3-setuptools"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/ghantoos/$pkgname/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ghantoos/lshell/archive/$pkgver.tar.gz"
build() {
- python2 setup.py build
+ python3 setup.py build
}
package() {
- python2 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="546e55fd04d9913adbf6ff181d365f0aff8c94131229d4be994b29e94b925943fb32f99dc145172938535565f69405d0edad5bd2d9b7125f8770d0f0c591fece lshell-0.9.18.tar.gz"