aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lshw
diff options
context:
space:
mode:
authorEivind Uggedal <eivind@uggedal.com>2014-05-31 11:24:58 +0000
committerEivind Uggedal <eivind@uggedal.com>2014-05-31 11:24:58 +0000
commit64c7ca684f959122595d214f76901f3efeedd82e (patch)
treec65ec255c5ac2bfd9b373cabad66404caf59b646 /testing/lshw
parent6ea5ce68141da139c8f247e2633d801405c4cc5f (diff)
downloadaports-64c7ca684f959122595d214f76901f3efeedd82e.tar.bz2
aports-64c7ca684f959122595d214f76901f3efeedd82e.tar.xz
testing/lshw: moved to unmaintained
Diffstat (limited to 'testing/lshw')
-rw-r--r--testing/lshw/APKBUILD40
-rw-r--r--testing/lshw/lshw-gcc43.patch23
2 files changed, 0 insertions, 63 deletions
diff --git a/testing/lshw/APKBUILD b/testing/lshw/APKBUILD
deleted file mode 100644
index e26bbb717f..0000000000
--- a/testing/lshw/APKBUILD
+++ /dev/null
@@ -1,40 +0,0 @@
-# Contributor: Paul Kilar <pkilar@gmail.com>
-# Maintainer: Paul Kilar <pkilar@gmail.com>
-pkgname=lshw
-pkgver='02.17'
-pkgrel=0
-pkgdesc="Hardware Lister"
-url="http://ezix.org/project/wiki/HardwareLiSter"
-arch="all"
-license="GPL3+"
-depends=""
-depends_dev=""
-makedepends="sqlite-dev"
-install=""
-subpackages="$pkgname-doc $pkgname-lang"
-source="http://ezix.org/software/files/lshw-B.$pkgver.tar.gz"
-
-_builddir="$srcdir"/$pkgname-B.$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- make RPM_OPT_FLAGS=-DNONLS
-}
-
-package() {
- cd "$_builddir"
- make -j1 DESTDIR="$pkgdir" install
-}
-
-md5sums="a5feb796cb302850eaf5b4530888e3ed lshw-B.02.17.tar.gz"
-sha256sums="eb9cc053fa0f1e78685cb695596e73931bfb55d2377e3bc3b8b94aff4c5a489c lshw-B.02.17.tar.gz"
-sha512sums="868899dce98e786a08a2134d6e132c388d71ab0f03fa6e10881e14d7a882c1882b46bbc6bd6ddb021cfab87ad6c9fd369453c3916f0b3353027eb2d470e55d9b lshw-B.02.17.tar.gz"
diff --git a/testing/lshw/lshw-gcc43.patch b/testing/lshw/lshw-gcc43.patch
deleted file mode 100644
index c56b03890b..0000000000
--- a/testing/lshw/lshw-gcc43.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/core/abi.cc.orig 2010-03-15 21:26:20.000000000 +0100
-+++ src/core/abi.cc 2013-08-06 21:05:08.693772583 +0200
-@@ -11,6 +11,7 @@
- #include <unistd.h>
- #include <stdlib.h>
- #include <dirent.h>
-+#include <cstdlib>
-
- __ID("@(#) $Id: mem.cc 1352 2006-05-27 23:54:13Z ezix $");
-
-@@ -38,10 +39,10 @@
- for(i=0; i<n; i++)
- {
- system.addCapability(namelist[i]->d_name);
-- free(namelist[i]);
-+ std::free(namelist[i]);
- }
- if(namelist)
-- free(namelist);
-+ std::free(namelist);
- }
-
- popd();