aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lsmash
diff options
context:
space:
mode:
authorAlexander Edland <s@ocv.me>2018-08-05 07:17:13 +0200
committerShiz <hi@shiz.me>2018-08-05 20:59:20 +0200
commit6c807b79265b4c94fd6f2def377ff30c8edeb037 (patch)
treeb86d10f9db0a6611bd1e1beb7b14ca9f5839bdc0 /testing/lsmash
parent75154b31c3a60f6923077e7392af1d621758538c (diff)
downloadaports-6c807b79265b4c94fd6f2def377ff30c8edeb037.tar.bz2
aports-6c807b79265b4c94fd6f2def377ff30c8edeb037.tar.xz
testing/lsmash: new aport
Diffstat (limited to 'testing/lsmash')
-rw-r--r--testing/lsmash/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/lsmash/APKBUILD b/testing/lsmash/APKBUILD
new file mode 100644
index 0000000000..4ec5ba3ece
--- /dev/null
+++ b/testing/lsmash/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Alexander Edland <alpine@ocv.me>
+# Maintainer: Alexander Edland <alpine@ocv.me>
+pkgname=lsmash
+pkgver=2.14.5
+pkgrel=0
+pkgdesc="MP4 and MOV muxer/demuxer"
+url="https://github.com/l-smash/l-smash"
+arch="all"
+license="ISC"
+options="!check"
+subpackages="$pkgname-dev"
+source="lsmash-$pkgver.tar.gz::https://github.com/l-smash/l-smash/archive/v$pkgver.tar.gz"
+builddir="$srcdir/l-smash-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --extra-cflags=-fPIC \
+ --disable-static \
+ --enable-shared
+ make
+}
+
+package() {
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
+
+ # prefix binaries with lsmash- because
+ # /usr/bin/muxer is likely to cause collisions
+ for i in "$pkgdir"/usr/bin/*; do
+ mv "$i" "${i%/*}/lsmash-${i##*/}"
+ done
+}
+
+sha512sums="1dc38cd89d7b317b608d5f5f411ffeac3c1e7fdeea2fc2d7c09d209dce90756c51c27198c20199082fc2168f966a604cef3f9cfd2fd17086ae0f9c0bf50f1ec7 lsmash-2.14.5.tar.gz"