aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lua-ansicolors
diff options
context:
space:
mode:
authorGuilherme Felipe da Silva <gfsilva.eng@gmail.com>2020-03-04 13:31:50 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-09 16:04:48 -0300
commit2f350153495604b3c0b53f43ea5b9213aa4fe7a7 (patch)
treec134864784989dea63b6a8d2d383196d7becd62d /testing/lua-ansicolors
parentd46217483e379a9ea0327a76b3d55847fb545eef (diff)
downloadaports-2f350153495604b3c0b53f43ea5b9213aa4fe7a7.tar.bz2
aports-2f350153495604b3c0b53f43ea5b9213aa4fe7a7.tar.xz
testing/lua-ansicolors: prevent manifest overwrite
The luarocks manifest file is managed by luarocks itself, remove it from build to prevent overwrite
Diffstat (limited to 'testing/lua-ansicolors')
-rw-r--r--testing/lua-ansicolors/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/testing/lua-ansicolors/APKBUILD b/testing/lua-ansicolors/APKBUILD
index 347100777d..ec8057507d 100644
--- a/testing/lua-ansicolors/APKBUILD
+++ b/testing/lua-ansicolors/APKBUILD
@@ -2,7 +2,7 @@
pkgname=lua-ansicolors
_rockname="${pkgname#lua-}"
pkgver=1.0.2
-pkgrel=0
+pkgrel=1
pkgdesc="ANSI terminal color manipulation for Lua"
url="https://github.com/kikito/ansicolors.lua"
license="MIT"
@@ -28,6 +28,8 @@ build() {
LUA_LIBDIR="$(pkg-config --variable=libdir lua$lver)" \
make --tree="./build" \
"$_rockname-${pkgver%??}-1.rockspec"
+
+ rm "./build/lib/luarocks/rocks-$lver/manifest"
done
}