aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lua-event
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-01 19:20:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-04-01 19:20:07 +0000
commit99241c94dbde19b1764a1a86a8f23a1058560d88 (patch)
treec62b89f53d79f434c042d3d456569e0fe404e7a9 /testing/lua-event
parentf4772207a7880b690e051ff330327314c66a4d82 (diff)
downloadaports-99241c94dbde19b1764a1a86a8f23a1058560d88.tar.bz2
aports-99241c94dbde19b1764a1a86a8f23a1058560d88.tar.xz
testing/lua-event: select lua version with install_if
Diffstat (limited to 'testing/lua-event')
-rw-r--r--testing/lua-event/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/testing/lua-event/APKBUILD b/testing/lua-event/APKBUILD
index 144629621d..d67c4c7312 100644
--- a/testing/lua-event/APKBUILD
+++ b/testing/lua-event/APKBUILD
@@ -5,7 +5,7 @@ _luaversions="5.1 5.2"
pkgname=lua-event
_n=${pkgname#lua-}
pkgver=0.4.3
-pkgrel=1
+pkgrel=2
pkgdesc="Lua binding for libevent"
url="https://github.com/harningt/luaevent"
arch="all"
@@ -19,7 +19,6 @@ source="${url}/archive/v${pkgver}.tar.gz"
for _i in $_luaversions; do
makedepends="$makedepends lua${_i}-dev"
subpackages="$subpackages lua${_i}-${_n}:_split${_i/./}"
- depends="$depends lua${_i}-${_n}"
done
@@ -64,6 +63,7 @@ _split() {
local d= _ver=$1
pkgdesc="$pkgdesc - for Lua $_ver"
depends=
+ install_if="lua$_ver $pkgname=$pkgver-r$pkgrel"
for d in usr/lib/lua usr/share/lua; do
if [ -d "$pkgdir"/$d/$_ver ]; then
mkdir -p "$subpkgdir"/$d