aboutsummaryrefslogtreecommitdiffstats
path: root/testing/lua-ljsyscall
diff options
context:
space:
mode:
authorMichael Zuo <muh.muhten@gmail.com>2015-11-30 16:00:27 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2015-12-08 14:26:59 +0000
commit94223ef59bafa2c727b305de0bf23c2cc34a772a (patch)
treeb5bc7f3e6c16263dcee27bd795e43b30b2c3e295 /testing/lua-ljsyscall
parent4c74291c6d7d5805b868458332db386cb0f79c84 (diff)
downloadaports-94223ef59bafa2c727b305de0bf23c2cc34a772a.tar.bz2
aports-94223ef59bafa2c727b305de0bf23c2cc34a772a.tar.xz
testing/lua-ljsyscall: new aport
Diffstat (limited to 'testing/lua-ljsyscall')
-rw-r--r--testing/lua-ljsyscall/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/lua-ljsyscall/APKBUILD b/testing/lua-ljsyscall/APKBUILD
new file mode 100644
index 0000000000..722bbed8cb
--- /dev/null
+++ b/testing/lua-ljsyscall/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Michael Zuo <muh.muhten@gmail.com>
+# Maintainer: Michael Zuo <muh.muhten@gmail.com>
+pkgname=lua-ljsyscall
+pkgver=0.10
+pkgrel=0
+pkgdesc="LuaJIT Unix syscall FFI"
+url="http://www.myriabit.com/ljsyscall/"
+arch="noarch"
+license="MIT"
+depends=""
+makedepends="luajit"
+source="${pkgname#lua-}-$pkgver.tar.gz::https://github.com/justincormack/ljsyscall/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir/${pkgname#lua-}-$pkgver"
+build() {
+ cd "$_builddir"
+ find syscall/* -maxdepth 0 \
+ -type d \
+ -not -name linux \
+ -not -name shared \
+ -exec rm -r {} +
+ # we don't target mips, so no special case
+ find -H syscall/linux/* -maxdepth 0 \
+ -type d \
+ -not -name "`luajit -e 'print(jit.arch)'`" \
+ -exec rm -r {} +
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir/usr/share/lua/5.1"
+ cp -a syscall.lua syscall "$pkgdir/usr/share/lua/5.1"
+}
+
+md5sums="4a9a4ba447ade992e18a598722fce559 ljsyscall-0.10.tar.gz"
+sha256sums="9b5ba2b5798c5bc33aa2158f3b44f730de12497c195764aa1bc3d3f1244df198 ljsyscall-0.10.tar.gz"
+sha512sums="f2ed03ea2c524e3d8de1d80906b55029c6448cbbd83249c780f0e153875a84fd1af6cf37889242df31c1259cac3cab3ec7bdaf08b26ff75af25406a821b45945 ljsyscall-0.10.tar.gz"